summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2017-07-30 18:43:09 +0200
committerMichel Zou2017-07-30 18:43:09 +0200
commitd633e89df705fdbef4f732c4727f11c9a6f98508 (patch)
treea42e54b78c6b3c3a0635262030a39d5018f30d5a /PKGBUILD
parent4827a73f96aa3648ad65c64e4a8c7145c3538867 (diff)
downloadaur-d633e89df705fdbef4f732c4727f11c9a6f98508.tar.gz
fix dll install
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f95c35f8cfca..3bb454bfa3d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-asmjit
-pkgver=r102.d7fc62d
+pkgver=r255.1370fe6
pkgrel=1
pkgdesc="Complete x86/x64 JIT and Remote Assembler for C++ (mingw-w64)"
arch=('any')
@@ -21,8 +21,11 @@ pkgver() {
build () {
cd "$srcdir/asmjit"
+
+ # https://github.com/asmjit/asmjit/pull/177
+ sed -i 's|DESTINATION "lib\${LIB_SUFFIX}")|LIBRARY DESTINATION lib\${LIB_SUFFIX} ARCHIVE DESTINATION lib\${LIB_SUFFIX} RUNTIME DESTINATION bin)|g' CxxProject.cmake
+
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \