summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2019-07-13 13:34:11 -0400
committerAndrew Sun2019-07-13 13:34:11 -0400
commitda85e8c38b67aed63dcbe3612657206ba4d9c761 (patch)
tree9058ad9bb46ce29c6dc432928fe6081f7a8bd09c /PKGBUILD
parent703acbafbebaa238ac40f236d7933319fc451020 (diff)
downloadaur-da85e8c38b67aed63dcbe3612657206ba4d9c761.tar.gz
bring back static libraries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 11 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 642ab0abeac9..a889a6c562b4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,29 @@
pkgname=mingw-w64-atk
pkgver=2.32.0
-pkgrel=1
+pkgrel=2
pkgdesc="A library providing a set of interfaces for accessibility (mingw-w64)"
arch=('any')
-url="https://developer.gnome.org/atk/"
-license=('LGPL2')
+url="https://gitlab.gnome.org/GNOME/atk"
+license=('LGPL')
makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'python')
depends=('mingw-w64-crt' 'mingw-w64-glib2')
options=('!strip' '!buildflags' 'staticlibs')
source=("http://ftp.gnome.org/pub/gnome/sources/atk/${pkgver%.*}/atk-${pkgver}.tar.xz")
-md5sums=('c10b0b2af3c199e42caa6275b845c49d')
+sha256sums=('cb41feda7fe4ef0daa024471438ea0219592baf7c291347e5a858bb64e4091cc')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd "${srcdir}/atk-${pkgver}/"
+ cd "${srcdir}/atk-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-meson .. -Ddocs=false -Dintrospection=false
+ ${_arch}-meson \
+ --buildtype=plain \
+ --default-library=both \
+ -Ddocs=false \
+ -Dintrospection=false \
+ ..
ninja
popd
done