summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2015-12-24 09:02:29 +0100
committerMichel Zou2015-12-24 09:02:29 +0100
commit14b105b383fcd9d009fcfd4f0b209fa506155aa1 (patch)
tree7303244193680deb674ae35fd7ab5d09638c8cd1 /PKGBUILD
parent24b623dfe4780768bcb7361f2c1e0a834acdfc35 (diff)
downloadaur-14b105b383fcd9d009fcfd4f0b209fa506155aa1.tar.gz
v1.60.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 5 insertions, 11 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e7527af3b22a..7277588b69fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Contributor: Daniel Kirchner <daniel@ekpyron.org>
pkgname=mingw-w64-boost
-pkgver=1.59.0
+pkgver=1.60.0
_boostver=${pkgver//./_}
-pkgrel=2
+pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
@@ -12,11 +12,9 @@ depends=('mingw-w64-crt' 'mingw-w64-zlib' 'mingw-w64-bzip2')
makedepends=('mingw-w64-gcc' 'bzip2' 'zlib' 'python2')
options=(!strip !buildflags staticlibs)
source=("http://downloads.sourceforge.net/boost/boost/${pkgver}/boost_${_boostver}.tar.bz2"
- boost-mingw.patch
- boost-mingw-1.59.0-serialization.patch)
-md5sums=('6aa9a5c6a4ca1016edd0ed1178e3cb87'
- '349127a0f1bcddfc189c56219bf39853'
- 'db4ed93452debd15b2cd165c438f9911')
+ boost-mingw.patch)
+md5sums=('65a840e1a0b13a558ff19eeb2c4f0cbe'
+ '30f8a21c4835ab0e729a1b7f08137bc1')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -26,10 +24,6 @@ prepare() {
# https://svn.boost.org/trac/boost/ticket/7262
patch -Np0 -i "${srcdir}"/boost-mingw.patch
- # see issue: https://github.com/boostorg/serialization/pull/19
- # patch from http://pkgs.fedoraproject.org/cgit/mingw-boost.git/tree/
- patch -p1 -i "${srcdir}"/boost-mingw-1.59.0-serialization.patch
-
cd "${srcdir}"
for _arch in ${_architectures}; do
rm -rf build-${_arch:3}