summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2021-06-10 15:20:05 +0200
committerMichel Zou2021-06-10 15:20:05 +0200
commit6335d51dbb12bb3d627a3d9dbb7c491a76c1b29b (patch)
tree25a0caaa8ea9c8180c284e0ce86ed73db9939fc2 /PKGBUILD
parent28f99e4b75e9b7b8024d50f69832984596651e40 (diff)
downloadaur-6335d51dbb12bb3d627a3d9dbb7c491a76c1b29b.tar.gz
1.76.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9197fa4c0201..836ad1172210 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-boost
-pkgver=1.75.0
+pkgver=1.76.0
_boostver=${pkgver//./_}
-pkgrel=2
+pkgrel=1
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
@@ -11,7 +11,7 @@ makedepends=('mingw-w64-gcc' 'mingw-w64-wine')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://boostorg.jfrog.io/artifactory/main/release/${pkgver}/source/boost_${_boostver}.tar.bz2"
"context-cross.patch" "stacktrace-cross.patch")
-sha256sums=('953db31e016db7bb207f11432bef7df100516eeb746843fa0486a222e3fd49cb'
+sha256sums=('f0397ba6e982c4450f27bf32a2a83292aba035b827a5623a14636ea583318c41'
'844e163845ea6e7ae1f8d26cb52f72c6e4645cdade1be081bc1d2cff5db0a918'
'333791abd17ea192e0aa90185bfb8938e8e3dc102b284db316b061b2067e2fc2')
@@ -27,9 +27,6 @@ prepare() {
# bypass libbacktrace detection
patch -p1 -d libs/stacktrace -i "${srcdir}"/stacktrace-cross.patch
- # https://github.com/boostorg/context/issues/136
- curl -L https://github.com/boostorg/context/commit/85783e8cbba03804e13b3d314112df6b089ed2c0.patch | patch -p1 -R -d libs/context
-
# enable thread_local with gcc 11.x
curl -L https://github.com/boostorg/config/pull/380.patch | patch -p2