summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2021-06-12 20:55:30 +0200
committerMichel Zou2021-06-12 20:55:30 +0200
commit697ae198567562e55f3fd43a02d5c8e963d8e59d (patch)
tree4317585dff6e3387da739145f30d383fdda84490 /PKGBUILD
parent6335d51dbb12bb3d627a3d9dbb7c491a76c1b29b (diff)
downloadaur-697ae198567562e55f3fd43a02d5c8e963d8e59d.tar.gz
winternl.h
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 836ad1172210..9f8566a1d3f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-boost
pkgver=1.76.0
_boostver=${pkgver//./_}
-pkgrel=1
+pkgrel=2
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
@@ -30,6 +30,9 @@ prepare() {
# enable thread_local with gcc 11.x
curl -L https://github.com/boostorg/config/pull/380.patch | patch -p2
+ # lowercase winternl.h
+ curl -L https://github.com/boostorg/process/pull/181.patch | patch -p2
+
cd "${srcdir}"
for _arch in ${_architectures}; do
rm -rf build-${_arch:3}