summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-11-30 12:11:41 +0100
committerMichel Zou2019-11-30 12:11:41 +0100
commitdfd03861494eed65ecf6221cf9e2fbaf6a0ae62a (patch)
treee7ec14d3246732c9dd60d0b5e00643cb2f029972 /PKGBUILD
parent4f84df88d6943338c5236ad4b24184458a511bbe (diff)
downloadaur-dfd03861494eed65ecf6221cf9e2fbaf6a0ae62a.tar.gz
LD_PRELOAD fix
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ccbea20e0986..2c9bc980967f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-boost
pkgver=1.71.0
_boostver=${pkgver//./_}
-pkgrel=3
+pkgrel=4
pkgdesc="Free peer-reviewed portable C++ source libraries (mingw-w64)"
arch=('any')
url="http://www.boost.org/"
@@ -13,7 +13,7 @@ source=("https://dl.bintray.com/boostorg/release/${pkgver}/source/boost_${_boost
"boost-mingw.patch" "jam-wine.patch")
sha256sums=('d73a8da01e8bf8c7eda40b4c84915071a8c8a0df4a6734537ddde4a8580524ee'
'11a5c39852e0513d871a0f74c2f1224efc602a0404db7cd83190712e49a6d3bc'
- '8af7d7fb6e45b0ded273415824ff56878a73800a067188327cf0fa351352bec1')
+ '5ca770bf155dbed4f96b1fcd358d515ad77a1ca7ae5e6d6b180939beceff05af')
_architectures="32:i686-w64-mingw32 64:x86_64-w64-mingw32"
@@ -50,7 +50,7 @@ package() {
for _arch in ${_architectures}; do
pushd "build-${_arch:3}"
export BOOST_CROSSCOMPILING_EMULATOR=/usr/bin/${_arch:3}-wine
- ./b2 -d2 -q ${MAKEFLAGS} \
+ LD_PRELOAD="" ./b2 -d2 -q ${MAKEFLAGS} \
target-os=windows \
variant=release \
threading=multi \