summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-01-03 10:14:48 +0100
committerMichel Zou2019-01-03 10:14:48 +0100
commit7a4c328e9fc428f79a4a098e7b67f8a6ed414649 (patch)
treea5f9f73310bef34fa8d59badba416b531c3dd1f3 /PKGBUILD
parentd9fcb579da0b0d810f60c8af614d124f23d93926 (diff)
downloadaur-7a4c328e9fc428f79a4a098e7b67f8a6ed414649.tar.gz
2.88
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 4 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 100a07636b07..fa560c812ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Paul Bienkowski <opatutlol@aol.com>
# Contributor: Christoph Zeiler <archNOSPAM_at_moonblade.dot.org>
pkgname=mingw-w64-bullet
-pkgver=2.87
+pkgver=2.88
pkgrel=1
pkgdesc="A 3D Collision Detection and Rigid Body Dynamics Library for games and animation (mingw-w64)"
arch=('any')
@@ -13,16 +13,13 @@ depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
makedepends=('mingw-w64-cmake')
source=("https://github.com/bulletphysics/bullet3/archive/${pkgver}.tar.gz")
-sha1sums=('31c6f6c4116f4d919eaa5119f9131bedc64d3951')
+sha256sums=('21c135775527754fc2929db1db5144e92ad0218ae72840a9f162acb467a7bbf9')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd ${srcdir}/bullet3-${pkgver}
- sed -i "s|FIND_PACKAGE(PythonLibs|#|g" CMakeLists.txt
- sed -i "s|Ws2tcpip.h|ws2tcpip.h|g" examples/ThirdPartyLibs/clsocket/src/SimpleSocket.h
- sed -i "s|Winsock2.h|winsock2.h|g" examples/ThirdPartyLibs/clsocket/src/StatTimer.h
- echo "target_link_libraries (BulletRobotics ws2_32 winmm)" >> Extras/BulletRobotics/CMakeLists.txt
+# echo "target_link_libraries (BulletRobotics ws2_32 winmm)" >> Extras/BulletRobotics/CMakeLists.txt
}
build() {
@@ -34,6 +31,7 @@ build() {
-DBUILD_BULLET2_DEMOS=OFF \
-DBUILD_OPENGL3_DEMOS=OFF \
-DBUILD_UNIT_TESTS=OFF \
+ -DBUILD_EXTRAS=OFF \
-DINSTALL_LIBS=1 \
-DUSE_GLUT=0 \
-DINSTALL_EXTRA_LIBS=1 \