summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-11-29 19:18:13 +0100
committerMichel Zou2019-11-29 19:18:13 +0100
commita9617ad9b3dbeb1d92b1d7e07f2e81eb16150944 (patch)
tree8cf7014884201a34f8c9101be82c9887af33cc5b /PKGBUILD
parent8995595e73f79614878d3a7a66fd3e90958c1f75 (diff)
downloadaur-a9617ad9b3dbeb1d92b1d7e07f2e81eb16150944.tar.gz
wget
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 5 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b29caa5121ec..8d25661742d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ url="https://github.com/coin-or-tools/ThirdParty-ASL/"
license=('MIT')
groups=('mingw-w64-coin-or')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-configure')
+makedepends=('mingw-w64-configure' 'mingw-w64-wine' 'wget')
options=('!buildflags' '!strip' 'staticlibs')
source=("https://github.com/coin-or-tools/ThirdParty-ASL/archive/releases/$pkgver.tar.gz")
sha256sums=('c6fa24ab952243f10f5231d49a46c206d239cffe5793f0ae46651adcc4da0b45')
@@ -17,6 +17,9 @@ _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "ThirdParty-ASL-releases-$pkgver"
./get.ASL
+
+ # run configuration exe through wine
+ sed -i "s|./a.out >arith.h|\$(MINGW_TARGET)-wine ./a.exe >arith.h|g" solvers/makefile.u
}
build() {
@@ -24,7 +27,7 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure lt_cv_deplibs_check_method=pass_all ..
- make
+ make MINGW_TARGET=${_arch}
popd
done
}