summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2018-06-11 20:27:38 +0200
committerMartchus2018-06-11 20:27:38 +0200
commit8820dec5cbfa54e35f6a99fff87a1e7458d2983a (patch)
treeca75c08b46f4299289d517c65e690a64f2a4009b /PKGBUILD
parent04d2741f5088c19c342d78681289cc019f31b1d5 (diff)
downloadaur-8820dec5cbfa54e35f6a99fff87a1e7458d2983a.tar.gz
Update to 1.14.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b3f2c0674825..146042e75e20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
_name=cppunit
pkgname=mingw-w64-cppunit
-pkgver=1.13.2
+pkgver=1.14.0
pkgrel=1
pkgdesc="A C++ unit testing framework (mingw-w64)"
arch=('any')
@@ -16,11 +16,21 @@ license=('LGPL')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
options=(!strip !buildflags !libtool staticlibs !emptydirs)
-source=("http://dev-www.libreoffice.org/src/${_name}-${pkgver}.tar.gz")
-md5sums=('d1c6bdd5a76c66d2c38331e2d287bc01')
+source=("https://dev-www.libreoffice.org/src/${_name}-${pkgver}.tar.gz"
+ 0001-Don-t-redefine-NOMINMAX.patch)
+sha256sums=('3d569869d27b48860210c758c4f313082103a5e58219a7669b52bfd29d674780'
+ '68ae7a200a6bea8669268665c9a2b80c96a90fbf07273749184ce7a7f190cd40')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/${_name}-${pkgver}"
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
+
build() {
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/${_name}-${pkgver}/build-${_arch}"
@@ -36,7 +46,8 @@ package() {
cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
rm -rf "${pkgdir}/usr/${_arch}/share/"
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -exec ${_arch}-strip -g {} \;
done
}