summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-12-02 22:44:09 +0100
committerMichel Zou2019-12-02 22:44:09 +0100
commit88118f0ec76c6290f299b02105b74941b0c232f9 (patch)
tree64c2a1eb3c48f8fc3f1334a0ff9ba90bbdaf2604 /PKGBUILD
parenta458def18656bdba9918b10a8ed61d44705ec7a0 (diff)
downloadaur-88118f0ec76c6290f299b02105b74941b0c232f9.tar.gz
mingw-w64-environment
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f24a2b759445..2bf6a478de44 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ url='http://www.netlib.org/f2c/index.html'
license=('custom')
arch=('any')
depends=('mingw-w64-crt')
-makedepends=('mingw-w64-gcc')
+makedepends=('mingw-w64-gcc' 'mingw-w64-environment')
options=('!buildflags' '!strip' 'staticlibs')
source=("http://www.netlib.org/f2c/libf2c.zip" libf2c-1.patch)
noextract=("libf2c.zip")
@@ -31,8 +31,9 @@ prepare() {
build() {
cd "${srcdir}"
for _arch in ${_architectures}; do
- cp -r libf2c build-${_arch} && pushd build-${_arch}
- make -f makefile.u CC=${_arch}-gcc AR=${_arch}-ar LD=${_arch}-ld RANLIB=${_arch}-ranlib CFLAGS='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions --param=ssp-buffer-size=4 -DUSE_CLOCK'
+ cp -r libf2c build-${_arch} && pushd build-${_arch}
+ source mingw-env ${_arch}
+ make -f makefile.u CFLAGS="${CFLAGS} -DUSE_CLOCK"
popd
done
}