summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorpingplug2018-08-24 11:26:28 +0800
committerpingplug2018-08-24 11:26:28 +0800
commit5b432a6f3f661d3e08e9191bcd0047e14fa91de4 (patch)
tree1edda4e8293063d6c55d40ac3ba26920a34fdb1f /PKGBUILD
parent7c96ee005659f5d8f9847761954f38091b7f1235 (diff)
downloadaur-5b432a6f3f661d3e08e9191bcd0047e14fa91de4.tar.gz
Updated to 2.13.0+17+gc78afa9
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD50
1 files changed, 30 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6202bebdd56b..2a7de56d5f7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,44 @@
+# Maintainer: pingplug <pingplug@foxmail.com>
+# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
+
+_commit=c78afa906699933e87889895ca2039887943b639 # master~43
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
pkgname=mingw-w64-fontconfig
-pkgver=2.13.0+10+g58f5285
+pkgver=2.13.0+17+gc78afa9
pkgrel=1
-_commit=58f52853d5689e897525a5926c1a222340d3f404 # master
pkgdesc="A library for configuring and customizing font access (mingw-w64)"
-arch=(any)
+arch=('any')
url="https://www.freedesktop.org/wiki/Software/fontconfig/"
-license=("custom")
-makedepends=(mingw-w64-configure git autoconf-archive gperf python-lxml python-six)
-depends=(mingw-w64-expat mingw-w64-freetype2)
-options=(staticlibs !strip !buildflags)
-source=("git+https://anongit.freedesktop.org/git/fontconfig#commit=$_commit"
-"0007-pkgconfig.mingw.patch")
+license=('custom')
+depends=('mingw-w64-expat'
+ 'mingw-w64-freetype2')
+makedepends=('mingw-w64-configure'
+ 'git'
+ 'autoconf-archive'
+ 'gperf'
+ 'python-lxml'
+ 'python-six')
+options=('!strip' 'staticlibs' '!buildflags')
+source=("git+https://anongit.freedesktop.org/git/fontconfig#commit=${_commit}"
+ "0007-pkgconfig.mingw.patch")
sha256sums=('SKIP'
'af373531873da46d0356305da5444c1ec74f443cd2635ea2db6b7dadd1561f5b')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-
pkgver() {
cd fontconfig
git describe --tags | sed 's/-/+/g'
}
prepare() {
- cd fontconfig
- patch -p1 -i ${srcdir}/0007-pkgconfig.mingw.patch
- NOCONFIGURE=1 ./autogen.sh
+ cd fontconfig
+ patch -p1 -i ${srcdir}/0007-pkgconfig.mingw.patch
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd fontconfig
+ cd fontconfig
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
--with-arch=${_arch%-w64-mingw32} \
@@ -43,9 +51,11 @@ build() {
package() {
for _arch in ${_architectures}; do
cd "${srcdir}/fontconfig/build-${_arch}"
- make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
- find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
+ make DESTDIR="${pkgdir}" install
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs ${_arch}-strip -g
done
}
+
+# vim:set ts=2 sw=2 et: