summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2016-07-12 17:39:02 +0200
committerMartchus2016-07-12 17:39:48 +0200
commitfaafba3fc33930891d5776169675a3b9d1ccc927 (patch)
tree02d1c6af4b81c23c0c61e16104b86784111772e6 /PKGBUILD
parentc5a3c3f6540fd93c87ebe0aff42b1dcd727f74a1 (diff)
downloadaur-faafba3fc33930891d5776169675a3b9d1ccc927.tar.gz
Update to 2.6.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD61
1 files changed, 38 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 595025138cf8..ea25ce391c5c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,45 +1,60 @@
# Maintainer: Martchus <martchus@gmx.net>
+
+# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
+# you also find the URL of a binary repository.
+
pkgname=mingw-w64-freetype2
-pkgver=2.6.3
+pkgver=2.6.5
pkgrel=1
pkgdesc="TrueType font rendering library (mingw-w64)"
arch=('any')
url="http://www.freetype.org/"
license=('GPL')
-# adding harfbuzz for improved OpenType features auto-hinting
-# introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
-depends=(mingw-w64-crt mingw-w64-zlib mingw-w64-harfbuzz mingw-w64-bzip2)
+depends=(mingw-w64-crt mingw-w64-zlib mingw-w64-bzip2)
makedepends=(mingw-w64-gcc mingw-w64-configure)
-provides=(mingw-w64-freetype $pkgname-bootstrap)
-replaces=(mingw-w64-freetype $pkgname-bootstrap)
-conflicts=(mingw-w64-freetype $pkgname-bootstrap)
+provides=(mingw-w64-freetype)
+replaces=(mingw-w64-freetype)
+conflicts=(mingw-w64-freetype)
source=(http://download.savannah.gnu.org/releases/freetype/freetype-${pkgver}.tar.bz2{,.sig}
0001-Enable-table-validation-modules.patch
0002-Enable-subpixel-rendering.patch
- 0003-Enable-subpixel-hinting.patch
- 0004-Mask-subpixel-hinting-with-an-env-var.patch)
+ 0003-Make-subpixel-hinting-mode-configurable.patch
+ 0004-Keep-default-interpreter-version-as-35.patch)
options=(!strip !buildflags !libtool staticlibs)
-sha1sums=('6c98bd5d0be313207c37ca23d25faf983486aee5'
+sha1sums=('5db38ae2308c5a2c519c8e071e98b70d61585201'
'SKIP'
- '1c7bc438df0428a63f881e7e4343b22c5b09ecb1'
- 'e2d2b8c4847ab9cfd497179c7140835e99ece711'
- 'ebe3d7a6fc41304a77c23cb56e94dc718146d963'
- 'f50c70080f3fbee45b9c4264d8ae37eb4f1ac335')
+ 'e1fde7854d2a64868a5eef07415ad23c339fc630'
+ '7da3af8e1e002e39a247c37a05a10beb576007d6'
+ 'c64ba9d37732fc75de7817d1d679a3e38efdb4cb'
+ '1f30feeba9c51c9ec745bd29ef07beccf9544338')
validpgpkeys=('58E0C111E39F5408C5D3EC76C1A60EACE707FDA5')
+if [[ $pkgname = "mingw-w64-freetype2-bootstrap" ]]; then
+ _provides=${pkgname%-bootstrap}
+else
+ _provides=${pkgname}-bootstrap
+ # adding harfbuzz for improved OpenType features auto-hinting
+ # introduces a cycle dep to harfbuzz depending on freetype wanted by upstream
+ depends+=(mingw-w64-harfbuzz)
+fi
+provides+=(${_provides})
+replaces+=(${_provides})
+conflicts+=(${_provides})
+
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "${srcdir}/freetype-${pkgver}"
- patch -Np1 -i "${srcdir}/0001-Enable-table-validation-modules.patch"
- patch -Np1 -i "${srcdir}/0002-Enable-subpixel-rendering.patch"
-
- # https://bugs.archlinux.org/task/35274
- patch -Np1 -i "${srcdir}/0003-Enable-subpixel-hinting.patch"
- # Provide a way to enable the above patch at runtime.
- # Hopefully just a temporary measure until fontconfig picks up
- # the necessary configurables.
- patch -Np1 -i "${srcdir}/0004-Mask-subpixel-hinting-with-an-env-var.patch"
+ patch -Np1 -i ../0001-Enable-table-validation-modules.patch
+ patch -Np1 -i ../0002-Enable-subpixel-rendering.patch
+
+ # Provide a way to set the default subpixel hinting mode
+ # at runtime, without depending on the application to do so.
+ patch -Np1 -i ../0003-Make-subpixel-hinting-mode-configurable.patch
+
+ # Keep the classic subpixel hinting mode as default, as expected
+ # by upstream for the 2.6 series
+ patch -Np1 -i ../0004-Keep-default-interpreter-version-as-35.patch
}
build() {