summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
author4shadoww2018-03-21 23:03:49 +0200
committer4shadoww2018-03-21 23:03:49 +0200
commit95648a32eb5766f9e53e57e119de04c06205d78f (patch)
tree1a4bfd186b08e478a80d8bdb9d63957ad84f85d7 /PKGBUILD
downloadaur-95648a32eb5766f9e53e57e119de04c06205d78f.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 21 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..14826bdf65a9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Noa-Emil Nissinen <aur dot satella at spamgourmet dot org>
+
+pkgname=mingw-w64-gcc-bin
+pkgver=7.3.0
+pkgrel=1
+pkgdesc="Cross GCC for the MinGW-w64 cross-compiler (pre-compiled)"
+arch=('x86_64')
+url="https://gcc.gnu.org/"
+license=('GPL')
+groups=('mingw-w64-toolchain' 'mingw-w64')
+depends=('zlib' 'libmpc' 'mingw-w64-crt' 'mingw-w64-binutils' 'mingw-w64-winpthreads' 'mingw-w64-headers')
+provides=('mingw-w64-gcc')
+conflicts=('mingw-w64-gcc')
+options=('!strip' 'staticlibs' '!emptydirs' '!buildflags')
+source=("https://github.com/4shadoww/mingw-w64-builds/releases/download/binary/$provides-$pkgver.tar.xz")
+md5sums=('965c28aee8cdda8b5933c5d2d0319c29')
+
+package() {
+ cd "$provides/"
+ cp -r * "$pkgdir/"
+}