summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2015-04-11 01:24:31 +0800
committerTing-Wei Lan2015-04-11 01:24:31 +0800
commit27873481ff34aaf81da0a88413ed0a441b177986 (patch)
treed524ef8f6e6b1e53306e812ef17ea0fac7703921 /PKGBUILD
parent9a067665c43862f51b0e01ac6124cc2a2d1ff1e2 (diff)
downloadaur-27873481ff34aaf81da0a88413ed0a441b177986.tar.gz
mingw-w64-{gdk-pixbuf2,gtk2,gtk3,libepoxy}: Follow MinGW package guidelines
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1a4047537a93..f9703b3056f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-gdk-pixbuf2
pkgver=2.31.3
-pkgrel=2
+pkgrel=3
pkgdesc='An image loading library (mingw-w64)'
arch=(any)
url='http://www.gtk.org'
@@ -40,9 +40,8 @@ package() {
cd "build-${_arch}"
make DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' | xargs -rtl1 rm
- find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip -x
- find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtl1 ${_arch}-strip -g
- rm -r "$pkgdir/usr/${_arch}/share"
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' | xargs -rtl1 ${_arch}-strip -g
cd ..
done
}