summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2016-10-15 00:07:06 +0800
committerTing-Wei Lan2016-10-15 00:18:52 +0800
commit781deccdd9bcada4edfc603d07e05af6d8727b13 (patch)
tree57d278c324cdbcaa57f2178423547255c82d831c /PKGBUILD
parente28b44200a2956ae970f376b201c77230ed0e970 (diff)
downloadaur-781deccdd9bcada4edfc603d07e05af6d8727b13.tar.gz
mingw-w64-{gdk-pixbuf2,gtk2,gtk3}: Package Windows executables
These executables are useful for testing libraries themselves.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 135865f6c976..0e4336bd7cf1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-gdk-pixbuf2
pkgver=2.36.0
-pkgrel=1
+pkgrel=2
pkgdesc='An image loading library (mingw-w64)'
arch=(any)
url='http://www.gtk.org'
@@ -42,9 +42,9 @@ package() {
for _arch in ${_architectures}; do
cd "build-${_arch}"
make DESTDIR="$pkgdir" install
- find "$pkgdir/usr/${_arch}" -name '*.exe' -o -name '*.bat' -o -name '*.def' -o -name '*.exp' -o -name '*.manifest' | xargs -rtl1 rm
- find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtl1 ${_arch}-strip --strip-unneeded
- find "$pkgdir/usr/${_arch}" -name '*.a' | xargs -rtl1 ${_arch}-strip -g
+ find "$pkgdir/usr/${_arch}" -name '*.exe' | xargs -rtL1 ${_arch}-strip
+ find "$pkgdir/usr/${_arch}" -name '*.dll' | xargs -rtL1 ${_arch}-strip --strip-unneeded
+ find "$pkgdir/usr/${_arch}" -name '*.a' -o -name '*.dll' | xargs -rtL1 ${_arch}-strip -g
rm -r "$pkgdir/usr/${_arch}/share/man"
cd ..
done