summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2023-09-17 16:22:08 +0200
committerMichel Zou2023-09-17 16:22:08 +0200
commita00820aa7ac53df32c5925c6fb627872def7be95 (patch)
tree34912d42338dad6d95d8343c207aab6d6e9fa294 /PKGBUILD
parentacf7d133c582fbf0afb6a52edef9ccefb55977cf (diff)
downloadaur-a00820aa7ac53df32c5925c6fb627872def7be95.tar.gz
static
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bb15c91c8bea..b7b530005c6c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -18,7 +18,7 @@ prepare () {
cd "${srcdir}"/GKlib-METIS-v5.1.1-DistDGL-0.5
curl -L https://github.com/KarypisLab/GKlib/pull/9.patch | patch -p1
curl -L https://github.com/KarypisLab/GKlib/commit/98d2d28a834b45f052412d2be80743d91b43477e.patch | patch -p1 -f || echo "nope"
- echo "target_link_libraries(GKlib regex)" >> CMakeLists.txt
+ echo "target_link_libraries(GKlib /usr/\${CMAKE_SYSTEM_PROCESSOR}-w64-mingw32/lib/libregex.a)" >> CMakeLists.txt
sed -i "s|LIBRARY DESTINATION lib/\${LINSTALL_PATH})|LIBRARY DESTINATION lib/\${LINSTALL_PATH} RUNTIME DESTINATION bin)|g" CMakeLists.txt
}