summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuildTools2015-10-08 18:45:09 -0700
committerBuildTools2015-10-08 18:45:09 -0700
commit1809d742324bad809623f5dac5bc5bf9669d7fed (patch)
tree0d2106d574bc32753efd04a980715a03a6e4ce87 /PKGBUILD
parentad3fc727882bbc97e675a590e6f44962ecdcb284 (diff)
downloadaur-1809d742324bad809623f5dac5bc5bf9669d7fed.tar.gz
2.46
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD46
1 files changed, 23 insertions, 23 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 57e39eca0cf0..59d85d4f288e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
-pkgver=2.44.1
-pkgrel=4
+pkgver=2.46.0
+pkgrel=1
arch=(any)
pkgdesc="Common C routines used by GTK+ and other libs (mingw-w64)"
depends=(mingw-w64-gettext mingw-w64-zlib mingw-w64-libffi mingw-w64-pcre mingw-w64-freetype2)
@@ -12,52 +12,52 @@ license=("LGPL")
options=(!strip !buildflags staticlibs !emptydirs)
url="http://www.gtk.org/"
source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.tar.xz"
+"0001-Revert-list-store-Fix-a-parameter-check.patch"
"0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
-"0002-GNetworkMonitorBase-don-t-fail-when-IPv6-support-is-.patch"
"0003-g_abort.all.patch"
"0004-glib-prefer-constructors-over-DllMain.patch"
"0005-glib-send-log-messages-to-correct-stdout-and-stderr.patch"
-"0015-fix-stat.all.patch"
-"0021-use-64bit-stat-for-localfile-size-calc.all.patch"
"0024-return-actually-written-data-in-printf.all.patch"
"0027-no_sys_if_nametoindex.patch"
"0028-inode_directory.patch"
-"0029-grand.all.patch")
-sha256sums=('8811deacaf8a503d0a9b701777ea079ca6a4277be10e3d730d2112735d5eca07'
- '1420d8a8cadef2d33d748b31e5ae9c385aee1351d267dabf7a6a68fed6dfe7db'
- '5551461a90386837356d2b56d4011e5272ba1d3e6bc4262275ea0b7d0dfbce82'
- '6df7b4e00aa7ded9e2e9e729dd1fb3f78e11c5936b316ebf9cf102c9043756f4'
- '7d1096d4a799df63939ded9437bcd39ad13ab71ba213ef7c83abd6ebf4efaf6e'
- '4e636326f39261dc359784853bd61a897f8bb2d438fffc256ae60bb580799f16'
- '9ba68777f48816cbee154084c10d0d577a021ef406606d5c2d230761cf82b66b'
- 'ad13c9aaa3d2ca7b1e3dcfd6d0c8043fa4fe45d8abb3659dbbc1fcbc412c10c7'
- '497d057e79943df233ca304c389f462d3c4bf55ab3267e94dbef892b79fe3274'
- 'cc3bf5af21ea2138d5022163c95fc4dd5f1fe9c7f4169cac84d5a92ce851b44a'
- '97384c3e72f7d419eaa2377aeb85a382ce5441c5858e2c986a70dd380d3e1c1b'
- 'b038511e9da94c75922612f1fb10f6f6f951094e8d58fe64c2fa397044446c40')
+"0029-grand.all.patch"
+"0030-right-wstat-for-64bit.patch"
+"revert-warn-glib-compile-schemas.patch")
+sha256sums=('b1cee83469ae7d80f17c267c37f090414e93960bd62d2b254a5a96fbc5baacb4'
+ '261ae2d2c7b94460f33ab569540313e21c9a50af38a7ebe8412e49f5b309af35'
+ 'ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3'
+ '1b24cc928f69f73599f83269a7b3eb7bf7efbe114109251e6765053a1e1f4cd6'
+ '7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6'
+ '94b705382b405bf8eae51c4f82afbf819b6caa5b3e51512be18c870b79947f88'
+ '8421aed91370cf8eb5f0dde443bbc63e5dd4c238c586053eab4fbbae2e005d8c'
+ '5cb481295ff86c2802030984d8b2bf6a3b1dcd5e5fe7b0be68b22d9116305837'
+ 'f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b'
+ 'dd26a015cdd65ee270251a11ef4c646000b26bb435992e6c997a615c1c14602e'
+ 'fe5b19dbb77b22abb1e4b4771bc1f97b3fce9f3b3792b83c83e439f76aeced3e'
+ '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd glib-$pkgver
+ patch -Np1 -i ../0001-Revert-list-store-Fix-a-parameter-check.patch
patch -Np1 -i "$srcdir/0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
- patch -Np1 -i ../0002-GNetworkMonitorBase-don-t-fail-when-IPv6-support-is-.patch
patch -Np1 -i "$srcdir/0003-g_abort.all.patch"
patch -Np1 -i "$srcdir/0004-glib-prefer-constructors-over-DllMain.patch"
- patch -Np0 -i "$srcdir/0005-glib-send-log-messages-to-correct-stdout-and-stderr.patch"
- patch -Np1 -i "$srcdir/0015-fix-stat.all.patch"
- patch -Np1 -i "$srcdir/0021-use-64bit-stat-for-localfile-size-calc.all.patch"
+ patch -Np1 -i "${srcdir}/0005-glib-send-log-messages-to-correct-stdout-and-stderr.patch"
patch -Np1 -i "$srcdir/0024-return-actually-written-data-in-printf.all.patch"
patch -Np1 -i "$srcdir/0027-no_sys_if_nametoindex.patch"
patch -Np1 -i "$srcdir/0028-inode_directory.patch"
patch -Np1 -i "${srcdir}/0029-grand.all.patch"
+ patch -Np1 -i "${srcdir}/0030-right-wstat-for-64bit.patch"
+ patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
NOCONFIGURE=1 ./autogen.sh
}
build() {
cd glib-$pkgver
- conf="--with-pcre=system --with-threads=win32"
+ conf="--with-pcre=system --with-threads=win32 --disable-fam"
for _arch in ${_architectures}; do
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
${_arch}-configure \