summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuildTools2016-04-17 12:49:28 -0700
committerBuildTools2016-04-17 12:49:28 -0700
commitfc865af7acce068fa89673a172a0dc3f4bb124d0 (patch)
tree73e8e11bc434c219880b7a8037ae7f50923f00e5 /PKGBUILD
parent40b1e0dd3d8d91621c92837636c16ad358fba667 (diff)
downloadaur-fc865af7acce068fa89673a172a0dc3f4bb124d0.tar.gz
2.48
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 10 insertions, 28 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 80fb4161c48c..94f57df0705d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: ant32 <antreimer@gmail.com>
# Contributor: Renato Silva <br.renatosilva@gmail.com>
pkgname=mingw-w64-glib2
-pkgver=2.46.2
-pkgrel=3
+pkgver=2.48.0
+pkgrel=1
arch=(any)
pkgdesc="Common C routines used by GTK+ and other libs (mingw-w64)"
depends=(mingw-w64-gettext mingw-w64-zlib mingw-w64-libffi mingw-w64-pcre mingw-w64-freetype2)
@@ -15,45 +15,27 @@ source=("http://ftp.gnome.org/pub/GNOME/sources/glib/${pkgver%.*}/glib-$pkgver.t
"0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
"0003-g_abort.all.patch"
"0004-glib-prefer-constructors-over-DllMain.patch"
-"0005-glib-send-log-messages-to-correct-stdout-and-stderr.patch"
-"0024-return-actually-written-data-in-printf.all.patch"
"0027-no_sys_if_nametoindex.patch"
"0028-inode_directory.patch"
-"0029-grand.all.patch"
-"0035-glib-fix-on-windows-when-using-bindings.patch"
-"revert-warn-glib-compile-schemas.patch"
-"memleak.patch")
-sha256sums=('5031722e37036719c1a09163cc6cf7c326e4c4f1f1e074b433c156862bd733db'
+"revert-warn-glib-compile-schemas.patch")
+sha256sums=('744be6931ca914c68af98dc38ff6b0cf8381d65e335060faddfbf04c17147c34'
'ef81e82e15fb3a71bad770be17fe4fea3f4d9cdee238d6caa39807eeea5da3e3'
'1b24cc928f69f73599f83269a7b3eb7bf7efbe114109251e6765053a1e1f4cd6'
'7b099af0c562f397458542482d6d1debe437f220762aa2ed94b2e6c4d43dd8a6'
- '94b705382b405bf8eae51c4f82afbf819b6caa5b3e51512be18c870b79947f88'
- '8421aed91370cf8eb5f0dde443bbc63e5dd4c238c586053eab4fbbae2e005d8c'
'5cb481295ff86c2802030984d8b2bf6a3b1dcd5e5fe7b0be68b22d9116305837'
'f7f06a90156fe0a308412512c359072922f7f0d19dd4bed30d863db18e48940b'
- 'dd26a015cdd65ee270251a11ef4c646000b26bb435992e6c997a615c1c14602e'
- 'af30ae85dc86647562f7585dc3960b1cb46a33eb11172949c3e69b86de019db4'
- '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97'
- '8337eeba4a32133d41575c8338fca32ac6a867e6e4a4e021355fcdeb606420a6')
+ '049240975cd2f1c88fbe7deb28af14d4ec7d2640495f7ca8980d873bb710cc97')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd glib-$pkgver
- patch -Np1 -i "$srcdir/0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
- patch -Np1 -i "$srcdir/0003-g_abort.all.patch"
- patch -Np1 -i "$srcdir/0004-glib-prefer-constructors-over-DllMain.patch"
- patch -Np1 -i "${srcdir}/0005-glib-send-log-messages-to-correct-stdout-and-stderr.patch"
- patch -Np1 -i "$srcdir/0024-return-actually-written-data-in-printf.all.patch"
- patch -Np1 -i "$srcdir/0027-no_sys_if_nametoindex.patch"
- patch -Np1 -i "$srcdir/0028-inode_directory.patch"
- patch -Np1 -i "${srcdir}/0029-grand.all.patch"
-
- # https://bugzilla.gnome.org/show_bug.cgi?id=734095
- patch -Np1 -i "${srcdir}/0035-glib-fix-on-windows-when-using-bindings.patch"
-
+ patch -Np1 -i .."/0001-Use-CreateFile-on-Win32-to-make-sure-g_unlink-always.patch"
+ patch -Np1 -i .."/0003-g_abort.all.patch"
+ patch -Np1 -i ../0004-glib-prefer-constructors-over-DllMain.patch
+ patch -Np1 -i ../"0027-no_sys_if_nametoindex.patch"
+ patch -Np1 -i ../"0028-inode_directory.patch"
patch -Rp1 -i ../revert-warn-glib-compile-schemas.patch
- patch -Np1 -i ../memleak.patch
NOCONFIGURE=1 ./autogen.sh
}