summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2018-07-09 00:14:51 +0200
committerMichel Zou2018-07-09 00:14:51 +0200
commit3a0d313d743d172a75a4ee59496dc27efa0be45e (patch)
tree939d8514d08281cd4e93e61dddedd24611795727 /PKGBUILD
parentf54f836c78777c746a4cb0598d8711391f65616e (diff)
downloadaur-3a0d313d743d172a75a4ee59496dc27efa0be45e.tar.gz
exeext
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf6f9d0f57b8..4ca48f8196d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,18 +8,26 @@ license=("LGPL3")
depends=(mingw-w64-crt)
makedepends=(mingw-w64-configure)
options=(staticlibs !strip !buildflags)
-source=("https://gmplib.org/download/gmp/gmp-${pkgver}.tar.xz")
-sha256sums=('87b565e89a9a684fe4ebeeddb8399dce2599f9c9049854ca8c0dfbdea0e21912')
+source=("https://gmplib.org/download/gmp/gmp-${pkgver}.tar.xz" exeext.patch)
+sha256sums=('87b565e89a9a684fe4ebeeddb8399dce2599f9c9049854ca8c0dfbdea0e21912' SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare () {
+ cd "${srcdir}/gmp-${pkgver}"
+
+ # run code generation executables with the right suffix
+ patch -p1 -i "${srcdir}"/exeext.patch
+ autoreconf -vfi
+}
+
build() {
cd "${srcdir}/gmp-${pkgver}"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
--enable-cxx \
- --disable-static
+ --disable-static mp_cv_prog_exeext_for_build=.exe
make
popd
done