summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorosfans2020-01-14 13:18:18 +0800
committerosfans2020-01-14 13:18:18 +0800
commit136f07e9fff149629a1b717c5a7003581c7b184d (patch)
tree8896648de81ef0265e98d0cc389b76c741f96f7d /PKGBUILD
parent640aeb0fd233283abfbbefcf4f7a2d48ec8848f7 (diff)
downloadaur-136f07e9fff149629a1b717c5a7003581c7b184d.tar.gz
0.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ab4c32b32e75..3bbae8af48a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_pkgname=glog
pkgname=mingw-w64-google-$_pkgname
-pkgver=0.3.5
+pkgver=0.4.0
pkgrel=1
pkgdesc="Logging library for C++ (mingw-w64)"
arch=(any)
@@ -13,13 +13,14 @@ url='https://github.com/google/glog'
makedepends=('make' 'mingw-w64-cmake')
options=(!strip !buildflags staticlibs)
source=("glog-$pkgver.tar.gz::https://github.com/google/glog/archive/v$pkgver.tar.gz")
-sha512sums=('SKIP')
+sha512sums=('b585f1819ade2075f6b61dc5aaca5c3f9d25601dba2bd08b6c49b96ac5f79db23c6b7f2042df003f7130497dd7241fcaa8b107d1f97385cb66ce52d3c554b176')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
#unset LDFLAGS
cd $_pkgname-$pkgver
- sed -i "s/BaseTsd/basetsd/" src/logging.cc
+ sed -i "/endif (HAVE_DBGHELP)/atarget_link_libraries (glog PUBLIC dbghelp ssp)" CMakeLists.txt
+ sed -i "s/check_symbol_exists (snprintf stdio.h HAVE_SNPRINTF)/set (HAVE_SNPRINTF 1)/" CMakeLists.txt
for _arch in ${_architectures}; do
mkdir -p build-$_arch
pushd build-$_arch
@@ -45,7 +46,8 @@ package() {
popd
# Lazy way of dealing with conflicting man and info pages...
rm -rf "${pkgdir}/usr/${_arch}/share"
- install -D -m644 COPYING "$pkgdir"/usr/${_arch}/share/licenses/$_pkgname/COPYING
+ rm -rf "${pkgdir}/usr/${_arch}/lib/cmake/"
+ install -D -m644 COPYING "$pkgdir"/usr/${_arch}/share/licenses/google-$_pkgname/COPYING
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done