summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLukas Spies2018-05-19 00:35:07 +0200
committerLukas Spies2018-05-19 00:35:07 +0200
commit380aa50edf80f62132a6b4fbbfcea8042f334846 (patch)
tree26c9f41eb83524df03efd14ddb0765e575b29c1e /PKGBUILD
parentdf55b6c8e269ff9899de242240dc995883c29e6d (diff)
downloadaur-380aa50edf80f62132a6b4fbbfcea8042f334846.tar.gz
update to 1.3.29, add libtool as depends and enable modules
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4e5991c87b98..4da75449cb56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Lukas Spies <luspi (AT) gmx _DOT_ de>
pkgname=mingw-w64-graphicsmagick
-pkgver=1.3.28
+pkgver=1.3.29
pkgrel=1
pkgdesc="Image processing system (mingw-w64)"
arch=('any')
@@ -12,10 +12,10 @@ optdepends=('mingw-w64-jasper: jp2 module'
'mingw-w64-libtiff: ps2, ps3, tiff modules'
'mingw-w64-ghostscript: pdf, ps modules')
makedepends=('mingw-w64-configure' 'mingw-w64-pcre' 'mingw-w64-libpng' 'mingw-w64-libxml2' 'mingw-w64-libtiff')
-depends=('mingw-w64-crt' 'mingw-w64-freetype2' 'mingw-w64-lcms2' 'mingw-w64-bzip2' 'mingw-w64-xz')
+depends=('mingw-w64-crt' 'mingw-w64-freetype2' 'mingw-w64-lcms2' 'mingw-w64-bzip2' 'mingw-w64-xz' 'mingw-w64-libtool')
options=('!strip' '!buildflags' 'staticlibs')
source=("ftp://ftp.graphicsmagick.org/pub/GraphicsMagick/1.3/GraphicsMagick-$pkgver.tar.xz")
-md5sums=('aec23df5ad1a5bf8f8e1b392f95eed55')
+md5sums=('ddde0dd239592db50c5378472355c03c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -28,9 +28,8 @@ build() {
mkdir -p build-${_arch} && pushd build-${_arch}
### NOTE ###
- # if you manage to get libltdl installed, you can add the flag '--with-modules' for support of synamically loaded modules
- # 1.3.28 doesn't compile with JPEG-2000 support (problems with jasper)
- ${_arch}-configure --enable-shared --without-x --with-quantum-depth=16 --with-threads --without-jp2
+ # 1.3.29 doesn't compile with JPEG-2000 support (problems with jasper)
+ ${_arch}-configure --enable-shared --without-x --with-quantum-depth=16 --with-threads --with-modules --without-jp2
sed -i "s/\/usr\/include/\/usr\/${_arch}\/include/g" Makefile
sed -i "s/\/usr\/lib/\/usr\/${_arch}\/lib/g" Makefile