summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTing-Wei Lan2019-02-13 00:29:38 +0800
committerTing-Wei Lan2019-02-13 00:29:38 +0800
commit68c61e7ad9cfbaea9781c223075bb9a9d0edbc26 (patch)
treee84bab42173ca8b3315d887e5fb2e8bcabecc4f2 /PKGBUILD
parent8990e193ac53841635fe461783d46bbb5286d39d (diff)
downloadaur-68c61e7ad9cfbaea9781c223075bb9a9d0edbc26.tar.gz
mingw-w64-gtk3: 3.24.4 -> 3.24.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 20 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 12de7897154d..d2468455be13 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: lantw44 at gmail dot com
pkgname=mingw-w64-gtk3
-pkgver=3.24.4
+pkgver=3.24.5
pkgrel=1
pkgdesc='GObject-based multi-platform GUI toolkit (mingw-w64)'
arch=('any')
@@ -12,6 +12,7 @@ makedepends=(
'mingw-w64-gcc'
'mingw-w64-pkg-config'
'mingw-w64-configure'
+ 'gobject-introspection'
'gtk-update-icon-cache'
'python') # python is required to run gdbus-codegen
depends=(
@@ -19,22 +20,38 @@ depends=(
'mingw-w64-adwaita-icon-theme'
'mingw-w64-atk>=2.15.1'
'mingw-w64-cairo>=1.14.2-3'
+ 'mingw-w64-fribidi>=0.19.7'
'mingw-w64-gdk-pixbuf2>=2.30.0'
'mingw-w64-glib2>=2.53.4'
'mingw-w64-libepoxy>=1.4'
'mingw-w64-pango>=1.41.0')
options=('!strip' '!buildflags' 'staticlibs')
-source=("https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz")
-sha256sums=('d84f59ff02a87cc90c9df4a572a13eca4e3506e2bf511e2b9cbdb4526fa0cb9c')
+source=(
+ "https://download.gnome.org/sources/gtk+/${pkgver%.*}/gtk+-${pkgver}.tar.xz"
+ 'gtk3-link-gdk-against-fribidi.patch'
+ 'gtk3-fribidi-private-dependency.patch')
+sha256sums=(
+ '0be5fb0d302bc3de26ab58c32990d895831e2b7c7418d0ffea1206d6a3ddb02f'
+ '7d92bc28c1b8d5aacc69d2414419a60a23e664e1ffe19835f79cea21b9f99864'
+ '8f3fceda7ec0deb93df405060e95e4aa65af94b10d75697057781e472535cfe9')
_architectures=('i686-w64-mingw32' 'x86_64-w64-mingw32')
prepare() {
cd "${srcdir}/gtk+-${pkgver}"
+ local source_file
+ for source_file in "${source[@]}"; do
+ case "${source_file}" in
+ *.patch)
+ patch -p1 < "${srcdir}/${source_file}"
+ ;;
+ esac
+ done
}
build() {
cd "${srcdir}/gtk+-${pkgver}"
+ autoreconf -fiv
for _arch in "${_architectures[@]}"; do
export PKG_CONFIG="${_arch}-pkg-config"
export PKG_CONFIG_FOR_BUILD="pkg-config"