summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-06-23 21:20:25 +0200
committerMichel Zou2016-06-23 21:20:25 +0200
commit58d1069888d379826941267c8d3801d3a20539f9 (patch)
tree97d1a304ce11bdbc45de8fe6b93f38257b09f3f8 /PKGBUILD
parentbde58bd8559ecfef9aa5ba5aa5f4c5870e588ae4 (diff)
downloadaur-58d1069888d379826941267c8d3801d3a20539f9.tar.gz
3.6.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 4 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aca274e410e4..3a8f1a798157 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
pkgname=mingw-w64-lapack
pkgname=('mingw-w64-lapack' 'mingw-w64-blas' 'mingw-w64-cblas' 'mingw-w64-lapacke')
-pkgver=3.6.0
-pkgrel=2
+pkgver=3.6.1
+pkgrel=1
arch=('any')
pkgdesc="Linear Algebra PACKage (mingw-w64)"
makedepends=('mingw-w64-cmake')
@@ -10,20 +10,14 @@ options=('!buildflags' '!strip' 'staticlibs')
license=('LGPL')
url="http://www.netlib.org/lapack"
source=("http://www.netlib.org/lapack/lapack-${pkgver}.tgz")
-sha1sums=('7e993de16d80d52b22b6093465eeb90c93c7a2e7')
+sha1sums=('7220a9bc9c766cb513007f313b804d88f110c228')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "$srcdir/lapack-${pkgver}"
- sed -e 's|/CMAKE/|/cmake/|' -i CBLAS/CMakeLists.txt
-}
-
build()
{
cd "$srcdir/lapack-${pkgver}"
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch}-static && pushd build-${_arch}-static
${_arch}-cmake \
-DCMAKE_BUILD_TYPE=Release \
@@ -107,4 +101,4 @@ package_mingw-w64-lapacke()
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done
-} \ No newline at end of file
+}