summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-12-29 19:29:22 +0100
committerMichel Zou2016-12-29 19:29:22 +0100
commitd4b31523d17353eae7a0592f0545d0bdcdee108d (patch)
tree38ae75b7931432a4e63550473d558b822f21d81d /PKGBUILD
parent58d1069888d379826941267c8d3801d3a20539f9 (diff)
downloadaur-d4b31523d17353eae7a0592f0545d0bdcdee108d.tar.gz
3.7.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 3a8f1a798157..b173f708d698 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-lapack
pkgname=('mingw-w64-lapack' 'mingw-w64-blas' 'mingw-w64-cblas' 'mingw-w64-lapacke')
-pkgver=3.6.1
+pkgver=3.7.0
pkgrel=1
arch=('any')
pkgdesc="Linear Algebra PACKage (mingw-w64)"
@@ -9,11 +9,17 @@ makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
license=('LGPL')
url="http://www.netlib.org/lapack"
-source=("http://www.netlib.org/lapack/lapack-${pkgver}.tgz")
-sha1sums=('7220a9bc9c766cb513007f313b804d88f110c228')
+source=("http://www.netlib.org/lapack/lapack-${pkgver}.tgz" conversion.patch)
+sha1sums=('27dbd06bedc76619150f8e28de6412f7df0c649a' SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare()
+{
+ cd "$srcdir/lapack-${pkgver}"
+ patch -p1 -i "${srcdir}/conversion.patch"
+}
+
build()
{
cd "$srcdir/lapack-${pkgver}"