summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2018-06-11 20:53:29 +0200
committerMartchus2018-06-11 20:53:29 +0200
commit7d13a7f01adc40911073d1584c9528265692fa26 (patch)
tree5451e928aa77eaad43def0d4c5c881fbf23edc55 /PKGBUILD
parenta3ca34df1e057dc5e5ec206d35fae2183443d134 (diff)
downloadaur-mingw-w64-libfilezilla.tar.gz
Update to 0.12.2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 65fb22540608..2d0362721573 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,18 @@
_name=libfilezilla
pkgname=mingw-w64-libfilezilla
-pkgver=0.5.2
+pkgver=0.12.2
pkgrel=1
-pkgdesc="Library used by FileZilla (mingw-w64)"
+pkgdesc='Small and modern C++ library, offering some basic functionality to build high-performing, platform-independent programs (mingw-w64)'
arch=('any')
-url="https://filezilla-project.org/"
+url='https://filezilla-project.org/'
license=('GPL')
depends=('mingw-w64-crt')
makedepends=('mingw-w64-configure')
-options=(staticlibs !strip !buildflags)
+options=(staticlibs !strip !buildflags !makeflags)
install=
-source=("http://downloads.sourceforge.net/project/filezilla/libfilezilla/${pkgver}/${_name}-${pkgver}.tar.bz2")
-md5sums=('be50726969cabda0f1b1c9ee432c1f4e')
+source=("http://download.filezilla-project.org/libfilezilla/libfilezilla-$pkgver.tar.bz2")
+md5sums=('79c95ee58bc8db2fa3690a36ece25a6d')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -26,9 +26,12 @@ prepare() {
}
build() {
+ export CXXFLAGS='-O0'
for _arch in ${_architectures}; do
mkdir -p "${srcdir}/${_name}-${pkgver}/build-${_arch}" && cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
- ${_arch}-configure
+ ${_arch}-configure --disable-shared
+ # shared build doesn't work because 'fz::simple_event<fz::timer_event_type, unsigned long long>::type()'
+ # is not exportet correctly
make
done
}
@@ -37,7 +40,8 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/${_name}-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
- ${_arch}-strip -g "${pkgdir}/usr/${_arch}/lib/"*.a
- ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ find "${pkgdir}/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip --strip-all {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;
+ find "${pkgdir}/usr/${_arch}" -name '*.a' -exec ${_arch}-strip -g {} \;
done
}