summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2020-09-24 14:13:55 -0400
committerPatrick Northon2020-09-24 14:13:55 -0400
commit004ae3ab92a08cef0eb761b87338b5ac2d0e20fe (patch)
tree3705b8debcc825a0f11e8eb58bcca8a35bba54cd /PKGBUILD
parentf24d1f3d91ffe5e6977d902192a263353d71444c (diff)
downloadaur-004ae3ab92a08cef0eb761b87338b5ac2d0e20fe.tar.gz
Add fix for missing inline.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7014f3c43759..98dc56efd5ca 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-libheif
pkgver=1.9.0
-pkgrel=1
+pkgrel=2
pkgdesc="HEIF file format decoder and encoder. (mingw-w64)"
url="https://github.com/strukturag/libheif"
license=("LGPL")
@@ -19,13 +19,20 @@ options=(!strip !buildflags staticlibs)
optdepends=()
sha256sums=(
"b9e1dde935675c451ff89517b46fe33d574fcbd0540c635296f512c7950c0dee"
+ "9ae4197f1fe1d2c78b9612581636055ca8599ad4c5633c191d78b5391f43155a"
)
source=(
"https://github.com/strukturag/libheif/archive/v${pkgver}.tar.gz"
+ "fix-missing-inline.patch"
)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "libheif-${pkgver}"
+ patch -uNp1 < "../fix-missing-inline.patch"
+}
+
build() {
_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" -DWITH_EXAMPLES=OFF )