summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-06-14 21:39:31 -0400
committerAndrew Sun2018-06-14 21:39:31 -0400
commit8896ac904300767d3db21ec8f431be65d88a063d (patch)
tree6f8e00a84fb41f57e5e6a528dc590e1719916b08 /PKGBUILD
parent515e0d97d1c5f961fed3a3c9f615cc7297a09ba4 (diff)
downloadaur-8896ac904300767d3db21ec8f431be65d88a063d.tar.gz
strip libraries
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f879ab5458b0..2e8d281330a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -36,6 +36,8 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/systre-${pkgver}/build-${_arch}"
make DESTDIR="${pkgdir}" install
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
install -D -m644 "${srcdir}/systre-${pkgver}/COPYING" "${pkgdir}/usr/${_arch}/share/licenses/libsystre/LICENSE"
done
}