summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAndrew Sun2018-11-11 08:59:46 -0500
committerAndrew Sun2018-11-11 08:59:46 -0500
commitb4522c5669caee654479811e304a99b88fe7665e (patch)
tree3a5ed80fcf268f3ee6297b6cea0eedee3d743966 /PKGBUILD
parent38aa39896382db3fc6df86b6ba6662b9648807b5 (diff)
downloadaur-b4522c5669caee654479811e304a99b88fe7665e.tar.gz
mingw-w64-libthai: make relocatable
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD17
1 files changed, 13 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0521ca27f1ff..b1a8bdacb6cb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,28 @@
pkgname=mingw-w64-libthai
pkgver=0.1.28
-pkgrel=1
+pkgrel=2
pkgdesc="Thai language support routines (mingw-w64)"
arch=('any')
url="https://linux.thai.net/projects/libthai"
license=('LGPL')
-makedepends=('mingw-w64-configure' 'libdatrie')
+makedepends=('mingw-w64-configure' 'libdatrie' 'autoconf-archive')
depends=('mingw-w64-crt' 'mingw-w64-libdatrie')
options=('!strip' '!buildflags' 'staticlibs')
-source=("https://linux.thai.net/pub/thailinux/software/libthai/libthai-${pkgver}.tar.xz")
-sha256sums=('ffe0a17b4b5aa11b153c15986800eca19f6c93a4025ffa5cf2cab2dcdf1ae911')
+source=("https://linux.thai.net/pub/thailinux/software/libthai/libthai-${pkgver}.tar.xz"
+ 'relocatable.patch')
+sha256sums=('ffe0a17b4b5aa11b153c15986800eca19f6c93a4025ffa5cf2cab2dcdf1ae911'
+ 'f258c748e37a11ce20d307a9a27cf68de9543d79b7e60ebd31c7cf4398b5f6d9')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "${srcdir}/libthai-${pkgver}"
+
+ patch -Np1 -i "${srcdir}"/relocatable.patch
+ autoreconf -fiv
+}
+
build() {
cd "${srcdir}/libthai-$pkgver/"
for _arch in ${_architectures}; do