summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-03-31 20:06:28 +0200
committerMichel Zou2019-03-31 20:06:28 +0200
commit494249d7d3552ff2498a9f1eef1e34bf1aa278a6 (patch)
treee7856adc98ac09851bff8aea0ed0fea06630dc18 /PKGBUILD
parent5f321644d66fc2aa1cdcfd1d31818b5df5d3c7fb (diff)
downloadaur-494249d7d3552ff2498a9f1eef1e34bf1aa278a6.tar.gz
8.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 64fc68484a64..f90da7ed2aba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=('mingw-w64-llvm')
-pkgver=7.0.1
+pkgver=8.0.0
pkgrel=1
pkgdesc="Collection of modular and reusable compiler and toolchain technologies (mingw-w64)"
arch=('any')
@@ -10,7 +10,7 @@ depends=('mingw-w64-crt')
makedepends=('mingw-w64-cmake' 'llvm' 'python2')
options=('!strip' '!buildflags' 'staticlibs')
source=("https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz")
-sha256sums=('a38dfc4db47102ec79dcc2aa61e93722c5f6f06f0a961073bd84b78fb949419b')
+sha256sums=('8872be1b12c61450cacc82b3d153eab02be2546ef34fa3580ed14137bb26224c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -31,6 +31,7 @@ build() {
-DLLVM_INFERRED_HOST_TRIPLE=x86_64-pc-linux-gnu \
-DLLVM_BUILD_LLVM_DYLIB=ON \
-DBUILD_SHARED_LIBS=OFF \
+ -DHAVE_STEADY_CLOCK=0 \
..
make
popd
@@ -42,6 +43,6 @@ package() {
cd "${srcdir}/llvm-$pkgver.src/build-${_arch}"
make DESTDIR="${pkgdir}" install
${_arch}-strip -g "${pkgdir}"/usr/${_arch}/lib/*.a
- ${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
+ #${_arch}-strip --strip-unneeded "${pkgdir}"/usr/${_arch}/bin/*.dll
done
}