summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-07-13 20:10:20 +0200
committerMichel Zou2016-07-13 20:10:20 +0200
commitdaba86cd7cf711e5ff41198f79bf3d369018822f (patch)
treee7f5cef0d86d2a3b0b51784a56e903892d9482bc /PKGBUILD
parente05b503ce835c9b5ed3bb673999a6a332820cd18 (diff)
downloadaur-mingw-w64-mcfgthread.tar.gz
add i686
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 2 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7fd1ee40f240..ecabbcb499e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,15 +12,14 @@ options=(!strip !buildflags staticlibs)
source=("https://github.com/lhmouse/mcfgthread/archive/alpha-0.9.tar.gz")
md5sums=('bbd2e4497255b314f5adf78a83063aad')
-# _architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-_architectures="x86_64-w64-mingw32"
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
cd "${srcdir}/mcfgthread-alpha-0.9"
autoreconf -vfi
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-configure ..
+ CFLAGS="-fno-exceptions" ${_arch}-configure ..
make
popd
done