summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2021-01-25 11:27:52 +0100
committerMichel Zou2021-01-25 11:27:52 +0100
commitfa6da073d424774b4229c8154870cf411e01d5c4 (patch)
tree7ceeeb83608e5dae4b327ec02f7d5cb1d62ad14a /PKGBUILD
downloadaur-fa6da073d424774b4229c8154870cf411e01d5c4.tar.gz
4.1.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9b3c3bff9abe
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+pkgname=mingw-w64-med
+pkgver=4.1.0
+pkgrel=1
+pkgdesc='Modelisation et Echanges de Donnees, i.e. Data Modelization and Exchanges - code-aster exchange module linked to hdf5'
+arch=('any')
+url='https://www.salome-platform.org/downloads'
+license=('LGPL')
+depends=('mingw-w64-hdf5')
+makedepends=('mingw-w64-cmake')
+options=('!buildflags' '!strip' 'staticlibs')
+source=("https://files.salome-platform.org/Salome/other/med-${pkgver}.tar.gz")
+sha256sums=('847db5d6fbc9ce6924cb4aea86362812c9a5ef6b9684377e4dd6879627651fce')
+
+_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+
+prepare() {
+ cd "${srcdir}/med-${pkgver}"
+ curl -L https://gist.githubusercontent.com/jedbrown/527ef81ff59a0dccf833da40fdd15a47/raw/7482f9a42fdd277f5f9cf0167ea7a3381032ca7a/hdf5-1.12.patch | patch -p1
+ sed -i 's/if H5_VERS_MINOR > 10/if 0/g' src/ci/MEDfileCompatibility.c
+ sed -i "s|Lmcons.h|lmcons.h|g" src/2.3.6/ci/MEDunvCr.c src/ci/MEDmeshUniversalNameWr.c
+}
+
+build() {
+ cd "${srcdir}/med-${pkgver}"
+ for _arch in ${_architectures}; do
+ mkdir -p build-${_arch} && pushd build-${_arch}
+ CPPFLAGS="-DH5_USE_110_API" ${_arch}-cmake -DMEDFILE_BUILD_TESTS=OFF -DMEDFILE_INSTALL_DOC=OFF ..
+ make
+ popd
+ done
+}
+
+package() {
+ for _arch in $_architectures; do
+ cd "$srcdir"/med-${pkgver}/build-${_arch}
+ make install DESTDIR="$pkgdir"
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
+ mv "$pkgdir"/usr/${_arch}/lib/*.dll "$pkgdir"/usr/${_arch}/bin
+ ${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
+ ${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
+ done
+}