summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-04-23 19:09:15 +0200
committerMichel Zou2019-04-23 19:09:15 +0200
commit7a24040ec989a0d7f1216f40ba6e3f67cfdc6687 (patch)
tree6a9fe34d4ade9c943ff1150a7dd944317e2e4b3d /PKGBUILD
parent7bf55f8b031101550f223aa7871eaca2673e8bf9 (diff)
downloadaur-7a24040ec989a0d7f1216f40ba6e3f67cfdc6687.tar.gz
dlfcn
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d388f092fbd8..d96266cce956 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@ arch=('any')
url="https://www.mesa3d.org/"
license=("custom")
makedepends=('mingw-w64-gcc' 'scons' 'python2-mako' 'mingw-w64-meson')
-depends=('mingw-w64-crt')
+depends=('mingw-w64-dlfcn')
options=('staticlibs' '!strip' '!buildflags')
validpgpkeys=('71C4B75620BC75708B4BDB254C95FAAB3EB073EC') # Dylan Baker <dylan@pnwbakers.com>
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig})
@@ -25,7 +25,7 @@ build() {
cd "${srcdir}"/mesa-${pkgver}
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-meson -Dplatforms=surfaceless -Dglx=disabled -Dllvm=false ..
+ ${_arch}-meson -Dplatforms=surfaceless -Dglx=disabled -Dllvm=false --includedir=/usr/${_arch}/include/mesa ..
ninja
popd
done