summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2019-09-25 22:14:25 +0200
committerMichel Zou2019-09-25 22:14:25 +0200
commit9c2e6d38e8a4c536be8a0a2bf16cbedb9ea46c05 (patch)
treeea05f266bb925554f50d7a421a3d844e30b975d5 /PKGBUILD
parent824a2b35cc0e75128b40bfb641db873099068911 (diff)
downloadaur-9c2e6d38e8a4c536be8a0a2bf16cbedb9ea46c05.tar.gz
19.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1ceb70ede414..46060bb9e1d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,25 @@
pkgname=mingw-w64-mesa
-pkgver=19.1.0
+pkgver=19.2.0
pkgrel=1
pkgdesc="An open-source implementation of the OpenGL specification (mingw-w64)"
arch=('any')
url="https://www.mesa3d.org/"
license=("custom")
-makedepends=('mingw-w64-gcc' 'scons' 'python2-mako')
+makedepends=('mingw-w64-gcc' 'scons' 'python-mako')
depends=('mingw-w64-dlfcn' 'mingw-w64-llvm')
options=('staticlibs' '!strip' '!buildflags')
validpgpkeys=(71C4B75620BC75708B4BDB254C95FAAB3EB073EC # Dylan Baker <dylan@pnwbakers.com>
A5CC9FEC93F2F837CB044912336909B6B25FADFA) # Juan A. Suarez Romero <jasuarez@igalia.com>
-source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig} mingw-posix.patch)
-sha256sums=('2a6c3af3a803389183168e449c536304cf03e0f82c4c9333077933543b9d02f3' SKIP SKIP)
+source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig} py3k.patch)
+sha256sums=('b060caa2a00f856431160ff7377d0e8f58f2aa48c16ee5a9e265ebdccb10852a' SKIP SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare () {
cd "${srcdir}"/mesa-${pkgver}
- # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/784
- patch -p1 -i "${srcdir}"/mingw-posix.patch
+
+ # https://gitlab.freedesktop.org/mesa/mesa/merge_requests/2127
+ patch -p1 -i "${srcdir}"/py3k.patch
# libLLVMSupport.a: undefined reference to `compressBound' (only with static llvm)
sed -i "s|'LLVMSupport',|'LLVMSupport', 'z',|g" scons/llvm.py