summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2022-03-10 18:54:55 +0100
committerMichel Zou2022-03-10 18:54:55 +0100
commit9fa42481fc5db1d3d06ed1ae53c9d9b8747052f6 (patch)
tree4e49ca0361384977d9346c637e2d9627b82e5381 /PKGBUILD
parent68ff82d7f770c3accd285f57e4137fc9ae6ef232 (diff)
downloadaur-9fa42481fc5db1d3d06ed1ae53c9d9b8747052f6.tar.gz
22.0.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 4 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index df08606fd098..6d8264fb73bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-mesa
-pkgver=21.3.4
+pkgver=22.0.0
pkgrel=1
pkgdesc="An open-source implementation of the OpenGL specification (mingw-w64)"
arch=('any')
@@ -15,7 +15,7 @@ validpgpkeys=('8703B6700E7EE06D7A39B8D6EDAE37B02CEB490D' # Emil Velikov <emil.l
'71C4B75620BC75708B4BDB254C95FAAB3EB073EC' # Dylan Baker <dylan@pnwbakers.com>
'57551DE15B968F6341C248F68D8E31AFC32428A6') # Eric Engestrom <eric@engestrom.ch>
source=(https://mesa.freedesktop.org/archive/mesa-${pkgver}.tar.xz{,.sig})
-sha256sums=('77104fd4a93bce69da3b0982f8ee88ba7c4fb98cfc491a669894339cdcd4a67d'
+sha256sums=('e6c41928b5b9917485bd67cec22d15e62cad7a358bf4c711a647979987601250'
'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -35,11 +35,8 @@ build() {
package() {
cd "${srcdir}"/mesa-${pkgver}
for _arch in ${_architectures}; do
- install -d "$pkgdir"/usr/${_arch}/bin
- install -m755 build-${_arch}/src/gallium/targets/libgl-gdi/opengl32.dll "$pkgdir"/usr/${_arch}/bin
- install -m755 build-${_arch}/src/gallium/targets/wgl/libgallium_wgl.dll "$pkgdir"/usr/${_arch}/bin
- install -m755 build-${_arch}/src/gallium/targets/lavapipe/vulkan_lvp.dll "$pkgdir"/usr/${_arch}/bin
- install -m644 build-${_arch}/src/gallium/targets/lavapipe/lvp_icd.*.json "$pkgdir"/usr/${_arch}/bin
+ DESTDIR="$pkgdir" ninja -C build-${_arch} install
+ rm -r "$pkgdir"/usr/${_arch}/{lib,include}
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
done
}