summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Murino2019-12-08 21:19:26 +0100
committerNicola Murino2019-12-08 21:19:26 +0100
commit787b3df407aeec6255bebf59960881312039db9c (patch)
treeae03b7752adb2179dbd58ac08df49a92319ba7d2 /PKGBUILD
parentdd344c749391da36d80b58ee17b6b123f9169468 (diff)
downloadaur-787b3df407aeec6255bebf59960881312039db9c.tar.gz
add sys_root to the cross file and install meson-cross-file-generator
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a430f423f04c..03b93058dd47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-meson
pkgver=1
-pkgrel=17
+pkgrel=18
arch=('any')
pkgdesc="Meson wrapper for MinGW (mingw-w64)"
depends=('meson' 'mingw-w64-gcc' 'mingw-w64-pkg-config')
@@ -12,7 +12,7 @@ license=("GPL")
url="http://fedoraproject.org/wiki/MinGW"
source=("toolchain_generator.py"
"meson-mingw-wrapper")
-sha256sums=('e7635c6cbb1c4c99fc41910083febfb3d0f7d4b6995537a2fb7ab55322ee2910'
+sha256sums=('eccc039b3d46cc6ed3f48d526c9434a28da80caa88d0d7240866ab7d0370d164'
'c91f2bbcafad7b742f13c6bd46324a03b70066b348621ce6a20f4a05005985ef')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -32,6 +32,7 @@ build() {
package() {
install -d "${pkgdir}"/usr/bin
install -d "${pkgdir}"/usr/share/mingw
+ install -m 755 "${srcdir}/toolchain_generator.py" "$pkgdir/usr/bin/meson-cross-file-generator"
for _arch in ${_architectures}; do
install -m 755 "${srcdir}/${_arch}-meson" "$pkgdir/usr/bin/${_arch}-meson"
install -m 644 toolchain-${_arch}.meson "${pkgdir}"/usr/share/mingw/