summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2016-12-23 09:50:48 +0100
committerMichel Zou2016-12-23 09:50:48 +0100
commit613f1a7d5e85d8280467d7d52f0c744d11a2cad9 (patch)
tree6a47e37de00ce9365a492f9bddf13ccdad4a014d /PKGBUILD
parentf7f9656b01c621048c88d28568404f3958a4b291 (diff)
downloadaur-613f1a7d5e85d8280467d7d52f0c744d11a2cad9.tar.gz
3.1.5
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 6 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index bf280f400f6a..3914d49e6a06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,26 @@
pkgname=mingw-w64-mpfr
-_pkgver=3.1.4
-_patchlevel=p4
+_pkgver=3.1.5
pkgver=$_pkgver
-#.$_patchlevel
pkgrel=1
pkgdesc="Multiple-precision floating-point library (mingw-w64)"
arch=(any)
url="http://www.mpfr.org"
license=("LGPL")
makedepends=('mingw-w64-configure')
-depends=("mingw-w64-gmp>=5.0")
+depends=("mingw-w64-gmp")
options=('staticlibs' '!strip' '!buildflags')
-source=("http://www.mpfr.org/mpfr-current/mpfr-${_pkgver}.tar.xz"{,.asc})
-md5sums=('064b2c18185038e404a401b830d59be8'
+source=(http://www.mpfr.org/mpfr-current/mpfr-${_pkgver}.tar.xz{,.asc})
+md5sums=('c4ac246cf9795a4491e7766002cd528f'
'SKIP')
validpgpkeys=('07F3DBBECC1A39605078094D980C197698C3739D')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
-prepare() {
- cd "$srcdir"/mpfr-$_pkgver
- #patch -p1 -i "$srcdir"/mpfr-${_pkgver}-${_patchlevel}.patch
-}
-
build() {
cd "$srcdir"/mpfr-${_pkgver}
for _arch in ${_architectures}; do
- unset LDFLAGS
mkdir -p build-${_arch} && pushd build-${_arch}
- $_arch-configure \
+ ${_arch}-configure \
--enable-shared \
--disable-static \
--enable-thread-safe
@@ -41,7 +33,7 @@ package() {
for _arch in ${_architectures}; do
cd "${srcdir}/mpfr-${_pkgver}/build-${_arch}"
make DESTDIR="$pkgdir" install
- rm -r "$pkgdir/usr/${_arch}/share"
+ rm -r "$pkgdir"/usr/${_arch}/share
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done