summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2024-01-24 22:13:54 +0100
committerMichel Zou2024-01-24 22:13:54 +0100
commit0d5cfc682d6786e0384b514df5e8696050bd4797 (patch)
tree898fa33c2199acdaf84d36dd180e8384425f1859 /PKGBUILD
parentd20860f4382eb2b37a0b28214b2f6d883ed26119 (diff)
downloadaur-mingw-w64-opencascade.tar.gz
7.8.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 8 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f3255ef6f425..4c4624c5162a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=mingw-w64-opencascade
-pkgver=7.5.1
-_pkgver=V7_5_1
+pkgver=7.8.0
+_pkgver=V7_8_0
pkgrel=1
pkgdesc="Open CASCADE Technology, 3D modeling & numerical simulation (mingw-w64)"
arch=('any')
@@ -12,14 +12,14 @@ makedepends=('mingw-w64-cmake')
options=('!buildflags' '!strip' 'staticlibs')
source=("opencascade-${pkgver}.tgz::https://git.dev.opencascade.org/gitweb/?p=occt.git;a=snapshot;h=refs/tags/${_pkgver};sf=tgz"
'fix-install-dir-references.patch')
-sha256sums=('3a43d8b50df78ade72786fa63bc8808deac6380189333663e7b4ef8558ae7739'
+sha256sums=('b9c8f0a9d523ac1a606697f95fc39d8acf1140d3728561b8010a604431b4e9cf'
'afb584aa453993ae8d9e2b983594558531ede735a5892754b812be30650c9fb5')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd "occt-${_pkgver}"
- patch -Np1 -i "$srcdir/fix-install-dir-references.patch"
+ # patch -Np1 -i "$srcdir/fix-install-dir-references.patch"
# cross paths
sed -i "s|CMAKE_FIND_ROOT_PATH_BOTH||g" adm/cmake/*.cmake
@@ -33,9 +33,6 @@ prepare() {
# find .dll.a extension
sed -i 's|set (CMAKE_FIND_LIBRARY_SUFFIXES |#set (CMAKE_FIND_LIBRARY_SUFFIXES |g' adm/cmake/*.cmake
-
- # msvc-specific inline asm syntax
- sed -i "s|defined(_M_IX86)|defined(_MSC_VER)|g" src/Standard/Standard.cxx
}
build() {
@@ -43,13 +40,15 @@ build() {
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-cmake \
+ -DCMAKE_BUILD_TYPE=Release \
-DUSE_FREEIMAGE=ON \
-DUSE_FFMPEG=ON \
-DUSE_VTK=OFF \
-DUSE_RAPIDJSON=ON \
-DUSE_TBB=ON \
-DBUILD_DOC_Overview=OFF \
- -D3RDPARTY_FREEIMAGE_LIBRARY_freeimage=/usr/${_arch}/lib/libFreeImage.dll.a \
+ -DUSE_TBB=OFF \
+ -DUSE_FFMPEG=OFF \
-DINSTALL_DIR_BIN=bin \
-DINSTALL_DIR_LIB=lib \
-DINSTALL_DIR_DATA=share/opencascade/data \
@@ -69,6 +68,7 @@ package() {
cd "$srcdir/occt-${_pkgver}/build-${_arch}"
make install DESTDIR="$pkgdir"
rm "$pkgdir"/usr/${_arch}/*.txt
+ rm "$pkgdir"/usr/${_arch}/bin/*.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll
${_arch}-strip -g "$pkgdir"/usr/${_arch}/lib/*.a
done