summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkfg2023-06-02 15:31:09 +0200
committerkfg2023-06-02 15:31:09 +0200
commit54939e22d26c49e9ac6847c938ce44cb64843a97 (patch)
tree24bea3f7a406a513dc2c11a6f8fec01236392f34 /PKGBUILD
parent8fd8f1a926c672ce0d2f9324dd0c7134e275bfe0 (diff)
downloadaur-54939e22d26c49e9ac6847c938ce44cb64843a97.tar.gz
Update to 0.4.34
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4fd6b86d161f..616397249a92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,24 +4,34 @@
# Contributor: Jan de Groot <jgc@archlinux.org>
pkgname=mingw-w64-orc
-pkgver=0.4.33
+pkgver=0.4.34
pkgrel=1
pkgdesc="Optimized Inner Loop Runtime Compiler (mingw-w64)"
-arch=('any')
-license=('custom:BSD')
+arch=(any)
+license=(custom:BSD)
url="https://gitlab.freedesktop.org/gstreamer/orc"
-depends=('mingw-w64-crt')
-makedepends=('mingw-w64-gcc' 'mingw-w64-meson' 'wine' 'git')
-options=('!strip' '!buildflags' '!libtool' 'staticlibs')
+depends=(mingw-w64-crt)
+makedepends=(
+ mingw-w64-gcc
+ mingw-w64-meson
+ wine
+ git
+)
+options=(
+ '!strip'
+ '!buildflags'
+ '!libtool'
+ staticlibs
+)
#source=(https://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz{,.asc}
-_commit=be26150a7ab2e19a0f9384109b97b6ed9c805cf6 # tags/0.4.33^0
+_commit=7d5bbada3f1c6cf34182abccf47a34d79b83fa97 # tags/0.4.34^0
source=("git+https://gitlab.freedesktop.org/gstreamer/orc.git#commit=$_commit"
meson_i686-w64-mingw32
meson_x86_64-w64-mingw32)
validpgpkeys=('7F4BC7CC3CA06F97336BBFEB0668CC1486C2D7B5') #Sebastian Dröge
-sha256sums=('SKIP'
- '3eed78156a85a6b8238cd9b64d37df1a0dd8ec9816e71c2ed7a70874289f8e2e'
- 'a07b08deafafabf9196dbc0583093fff8be9c45e29f73f7c286d5fc99492434d')
+b2sums=('SKIP'
+ '982c4e5403159748625fccdea5754e10c7f191e04058f76378271a63c5ff5aa7d093b22a004382e47837412e836ee2278e762c98aaceb47afe690e8e48ea8c43'
+ '96fe847dc06e9dd81ed0d28200275ef0ee8873666236b732c9933202e19d81f37625a2b7ca59056531877e9d4542a8faa34dba2f0bdcd87ac74b6c1360c3a4b7')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
@@ -64,3 +74,4 @@ package() {
#${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
done
}
+# vim:set sw=2 sts=-1 et: