summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorkfg2017-04-14 11:42:18 +0200
committerkfg2017-04-14 11:42:18 +0200
commitdaf52c2922f17c989988a89a199cf1e9d2883a76 (patch)
tree391cb3079d9a2c2d4652ddca6123c704d07563dc /PKGBUILD
parent3de0bbd5e55c3cc52ff356ae8d15d3f1af8eef89 (diff)
downloadaur-daf52c2922f17c989988a89a199cf1e9d2883a76.tar.gz
keep EXEs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a0801267a29e..f336cca206c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Karl-Felix Glatzer <karl.glatzer@gmx.de>
pkgname=mingw-w64-orc
pkgver=0.4.26
-pkgrel=1
+pkgrel=2
pkgdesc="Optimized Inner Loop Runtime Compiler (mingw-w64)"
arch=('any')
license=('custom')
@@ -9,8 +9,10 @@ url="https://cgit.freedesktop.org/gstreamer/orc/"
depends=('mingw-w64-crt')
makedepends=('mingw-w64-gcc' 'mingw-w64-configure')
options=('!strip' '!buildflags' '!libtool' 'staticlibs')
-source=(http://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz)
-sha256sums=('7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649')
+source=(https://gstreamer.freedesktop.org/data/src/orc/orc-${pkgver}.tar.xz{,.asc})
+validpgpkeys=('7F4BC7CC3CA06F97336BBFEB0668CC1486C2D7B5') #Sebastian Dröge
+sha256sums=('7d52fa80ef84988359c3434e1eea302d077a08987abdde6905678ebcad4fa649'
+ 'SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build () {
@@ -29,8 +31,8 @@ package() {
make DESTDIR="$pkgdir" install
install -Dm644 ${srcdir}/orc-$pkgver/COPYING "$pkgdir/usr/${_arch}/share/licenses/orc/COPYING"
+ ${_arch}-strip -s ${pkgdir}/usr/${_arch}/bin/*.exe
${_arch}-strip -x -g ${pkgdir}/usr/${_arch}/bin/*.dll
${_arch}-strip -g ${pkgdir}/usr/${_arch}/lib/*.a
- rm ${pkgdir}/usr/${_arch}/bin/*.exe
done
}