summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2020-04-22 08:41:46 +0200
committerMichel Zou2020-04-22 08:41:46 +0200
commitc7db5c34b1d24392cc961f34a36959584a739776 (patch)
treec209860ce9afd496010dd1fcc4de489bf8a79794 /PKGBUILD
parentf719745c8906bf8c49adcbbc7e2b7ea4add884cf (diff)
downloadaur-c7db5c34b1d24392cc961f34a36959584a739776.tar.gz
2.15.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 913a1c3fea94..db9c2e937ad1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,15 @@
pkgname=mingw-w64-pagmo
-pkgver=2.11.4
+pkgver=2.15.0
pkgrel=1
pkgdesc="Perform parallel computations of optimisation tasks (global and local) via the asynchronous generalized island model (mingw-w64)"
arch=('any')
url="https://github.com/esa/pagmo2"
license=('GPLv3')
-depends=('mingw-w64-boost' 'mingw-w64-intel-tbb')
-optdepends=('mingw-w64-gsl: Mathematical operations (symbolic)'
- 'mingw-w64-blas: GSL CBLAS functions'
- 'mingw-w64-nlopt: Nonlinear optimization algorithms')
-makedepends=('mingw-w64-cmake')
+depends=('mingw-w64-boost' 'mingw-w64-intel-tbb' 'mingw-w64-nlopt' 'mingw-w64-coin-or-ipopt')
+makedepends=('mingw-w64-cmake' 'mingw-w64-eigen')
options=('!buildflags' 'staticlibs' '!strip')
source=("https://github.com/esa/pagmo2/archive/v${pkgver}.tar.gz")
-sha512sums=('76c9c607b89a549b92101cb1712ef3bdaa8a20e3134479e4a58c61531e4770b9922bf01ee5c895acb1b21670f4e8cbcf8c7781f764ef182da4064939d2099bde')
+sha256sums=('07977be690b512ea11fc40d5b8bfa0a7a8507ce9053a615c2bc4725d355ef9a8')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -20,7 +17,7 @@ build() {
cd "${srcdir}/pagmo2-$pkgver"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
- ${_arch}-cmake ..
+ ${_arch}-cmake -DPAGMO_WITH_EIGEN3=ON -DPAGMO_WITH_NLOPT=ON -DPAGMO_WITH_IPOPT=ON ..
make
popd
done