summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSchala2017-02-27 18:17:13 -0800
committerSchala2017-02-27 18:17:13 -0800
commitedfa32837cfdb6a7ba8d7f741be08ae512e96f5d (patch)
tree04f74fe350b4775da95465142106767f434764f9 /PKGBUILD
parent294c79885cf552d04b09a0d69dd39f8fe91b99c1 (diff)
downloadaur-edfa32837cfdb6a7ba8d7f741be08ae512e96f5d.tar.gz
1.40.4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 51c0afc34fbf..df9183058516 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,31 @@
pkgname=mingw-w64-pango
-pkgver=1.40.3
-pkgrel=2
+pkgver=1.40.4
+pkgrel=1
+_commit=43b9668ba688b01553abb7b453aeb206d7fd56fa
pkgdesc="A library for layout and rendering of text (mingw-w64)"
arch=(any)
url="http://www.pango.org"
license=("LGPL")
-makedepends=(mingw-w64-configure gtk-doc)
+makedepends=(mingw-w64-configure gtk-doc git)
depends=(mingw-w64-harfbuzz mingw-w64-cairo)
options=(staticlibs !strip !buildflags !emptydirs)
-source=("http://ftp.gnome.org/pub/gnome/sources/pango/${pkgver:0:4}/pango-${pkgver}.tar.xz"
-"0001-no-unconditional-xft-please.all.patch")
-sha256sums=('abba8b5ce728520c3a0f1535eab19eac3c14aeef7faa5aded90017ceac2711d3'
- 'eccc044bbd156b252f5a13f7894c3a6cd1efc6ea80eaee57a5865895b192616d')
+source=("git+https://git.gnome.org/browse/pango#commit=$_commit")
+sha256sums=('SKIP')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+pkgver() {
+ cd "$srcdir/pango"
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
- cd "$srcdir/pango-$pkgver"
- patch -p1 -i ${srcdir}/0001-no-unconditional-xft-please.all.patch
- autoreconf -fi
+ cd "$srcdir/pango"
+ NOCONFIGURE=1 ./autogen.sh
sed -i 's/have_libthai=true/have_libthai=false/' configure
}
build() {
- cd pango-$pkgver
+ cd "$srcdir/pango"
for _arch in ${_architectures}; do
mkdir -p build-${_arch} && pushd build-${_arch}
${_arch}-configure \
@@ -37,7 +40,7 @@ build() {
package() {
for _arch in ${_architectures}; do
- cd "${srcdir}/pango-${pkgver}/build-${_arch}"
+ cd "${srcdir}/pango/build-${_arch}"
make -j1 DESTDIR="$pkgdir" install
find "$pkgdir/usr/${_arch}" -name '*.exe' -exec ${_arch}-strip {} \;
find "$pkgdir/usr/${_arch}" -name '*.dll' -exec ${_arch}-strip --strip-unneeded {} \;