summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBuildTools2017-08-17 19:48:54 -0700
committerBuildTools2017-08-17 19:48:54 -0700
commitbed82036a8ccd82c51ed13f50948330901a0788c (patch)
treed7421f1a16eddfcdc49f9a14a5b2fa6e94405ec6 /PKGBUILD
parent091bbabdf1aee14415b1d582c95ba59cb0bd1318 (diff)
downloadaur-bed82036a8ccd82c51ed13f50948330901a0788c.tar.gz
10.23
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 11 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0f42ce5ef57a..83f2396e0061 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=mingw-w64-pcre2
-pkgver=10.22
+pkgver=10.23
pkgrel=1
pkgdesc=" A library that implements Perl 5-style regular expressions. 2nd version (mingw-w64)"
arch=(any)
@@ -8,12 +8,19 @@ license=("BSD")
makedepends=(mingw-w64-configure mingw-w64-readline mingw-w64-bzip2 mingw-w64-zlib)
depends=(mingw-w64-crt)
options=(staticlibs !strip !buildflags)
-optdepends=(mingw-w64-readline mingw-w64-bzip2 mingw-w64-zlib)
-source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre2-$pkgver.tar.bz2")
-md5sums=('c0c02517938ee2b0d350d53edf450664')
+optdepends=(mingw-w64-wineditline mingw-w64-bzip2 mingw-w64-zlib)
+source=("ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/pcre2-$pkgver.tar.bz2"
+"bug_2067.patch")
+md5sums=('b2cd00ca7e24049040099b0a46bb3649'
+ '455e0e7bdb851f6c2fc5a208d880b49c')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+prepare() {
+ cd "$srcdir/pcre2-$pkgver"
+ patch -p1 -i ../bug_2067.patch
+}
+
build() {
cd "$srcdir/pcre2-$pkgver"
for _arch in ${_architectures}; do