summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEduardo Bart2022-12-10 07:01:10 -0300
committerEduardo Bart2022-12-10 07:01:10 -0300
commit46e642729a0a367a469f1af72a105ea5f9eb5831 (patch)
tree48764abef8bec0e302600f7be33e182e63a0ca30 /PKGBUILD
parenta8097c1f8fad730ed4e38d0ca514776b022fe89e (diff)
downloadaur-mingw-w64-physfs.tar.gz
Update to 3.2.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index dc69434f0bcb..8f62e8a6b9a7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: edub4rt <edub4rt@gmail.com>
pkgname=mingw-w64-physfs
_basename=physfs
-pkgver=3.0.2
+pkgver=3.2.0
pkgrel=1
pkgdesc="A library to provide abstract access to various archives (mingw-w64)"
arch=('any')
@@ -10,13 +10,13 @@ license=('ZLIB')
makedepends=('mingw-w64-cmake')
depends=('mingw-w64-zlib')
options=(staticlibs '!strip' '!buildflags' '!makeflags')
-source=(http://icculus.org/physfs/downloads/${_basename}-${pkgver}.tar.bz2)
-sha1sums=('6a15c458898d0570101d8f173201cde9ced78df7')
+source=(https://github.com/icculus/physfs/archive/refs/tags/release-${pkgver}.tar.gz)
+sha256sums=('1991500eaeb8d5325e3a8361847ff3bf8e03ec89252b7915e1f25b3f8ab5d560')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
build() {
- cd $_basename-$pkgver
+ cd $_basename-release-$pkgver
unset LDFLAGS
export CFLAGS="$CFLAGS -fno-strict-aliasing"
export CXXFLAGS="$CXXFLAGS -fno-strict-aliasing"
@@ -34,7 +34,7 @@ build() {
}
package() {
- cd $_basename-$pkgver
+ cd $_basename-release-$pkgver
for _arch in ${_architectures}; do
cd build-${_arch}
make DESTDIR=${pkgdir} install