summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorNicola Murino2019-12-23 19:30:01 +0100
committerNicola Murino2019-12-23 19:30:01 +0100
commit5a7fe6f9b9abc8edf1309fcc471370d23101af67 (patch)
treea1441a9682e22c540a8b0ee61ac3f7878a00f5d3 /PKGBUILD
parentdd031886c8806b0207d3d914fa0cc334d0215d7d (diff)
downloadaur-5a7fe6f9b9abc8edf1309fcc471370d23101af67.tar.gz
add needed patchs to the PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a8dee7c6e561..23d5c009da4b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: drakkan <nicola.murino at gmail dot com>
pkgname=mingw-w64-pixman
pkgver=0.38.4
-pkgrel=7
+pkgrel=8
pkgdesc="The pixel-manipulation library for X and cairo (mingw-w64)"
arch=(any)
url="http://xorg.freedesktop.org"
@@ -10,24 +10,28 @@ makedepends=(mingw-w64-meson mingw-w64-libpng)
depends=(mingw-w64-gcc)
options=(staticlibs !strip !buildflags)
source=("http://xorg.freedesktop.org/releases/individual/lib/pixman-${pkgver}.tar.bz2"
- "https://gitlab.freedesktop.org/pixman/pixman/commit/4851d4e20f66f540cd61fb69851df17671fc90d2.patch"
- "https://gitlab.freedesktop.org/pixman/pixman/commit/be0d3e699401f8230fa88c28c52d73c57f13f327.patch"
- "https://gitlab.freedesktop.org/pixman/pixman/commit/fd5c0da57985a430912907d4a898ed1ddb854ead.patch"
- "https://gitlab.freedesktop.org/pixman/pixman/merge_requests/13.diff")
+ "4851d4e20f66f540cd61fb69851df17671fc90d2.patch"
+ "be0d3e699401f8230fa88c28c52d73c57f13f327.patch"
+ "fd5c0da57985a430912907d4a898ed1ddb854ead.patch"
+ "afc6c935f1b52ca74d96f1ea2cbfb3e47ffb7fd4.patch")
sha256sums=('84abb7fa2541af24d9c3b34bf75d6ac60cc94ac4410061bbb295b66a29221550'
- '48374ee1ec7a95b4262e6a26d3f5596c17f01a28225ce4927ee9ad90e0205e88'
- '55977e70dc9013dabb2256def5c622ac3c8607a96d829f8c025a8a73b241b4e2'
- '8d7cf32ff224dae5f52fad337c38be3591fad4383679bbfe946685bf8bcec3ad'
- '0d7c3b9da2e8f6973aaeae9aedae91e51f383cfd58ca5b6b0d3bcc6162fd3cbd')
+ '8b4cdf460a1a3298aeb156c75b304c19d52421ad064f64866f002355bed94a06'
+ '3103cb4c482d150acdc08f901a1383bd5a6e044653dc3afc5b73919f73f529d1'
+ '2efc53fe4f0831441921884b4fb2896fbd14b865892c9cd5df4dfcd260c9bb41'
+ '8a708e65b528e73898c6b9690a1920d25fc3106928c28959694af3a5edad999b')
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
prepare() {
cd ${srcdir}/pixman-${pkgver}
+ # https://gitlab.freedesktop.org/pixman/pixman/commit/4851d4e20f66f540cd61fb69851df17671fc90d2.patch
patch -Np1 -i ../4851d4e20f66f540cd61fb69851df17671fc90d2.patch
+ # https://gitlab.freedesktop.org/pixman/pixman/commit/be0d3e699401f8230fa88c28c52d73c57f13f327.patch
patch -Np1 -i ../be0d3e699401f8230fa88c28c52d73c57f13f327.patch
+ # https://gitlab.freedesktop.org/pixman/pixman/commit/fd5c0da57985a430912907d4a898ed1ddb854ead.patch
patch -Np1 -i ../fd5c0da57985a430912907d4a898ed1ddb854ead.patch
- patch -Np1 -i ../13.diff
+ # https://gitlab.freedesktop.org/pixman/pixman/commit/afc6c935f1b52ca74d96f1ea2cbfb3e47ffb7fd4.patch
+ patch -Np1 -i ../afc6c935f1b52ca74d96f1ea2cbfb3e47ffb7fd4.patch
}
build() {