summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2021-11-21 04:06:39 -0500
committerPatrick Northon2021-11-21 04:06:39 -0500
commit482fe1e309aadba10174ecc853ff78ed30b7a924 (patch)
tree5f3bcb133ea39f8d9ea806e70a47f9113413a2b6 /PKGBUILD
parent126256f1e366e9908f23b162c145816140846367 (diff)
downloadaur-482fe1e309aadba10174ecc853ff78ed30b7a924.tar.gz
Small corrections.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 15 insertions, 14 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 029eaf9bc368..d994ebd8dffa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,34 @@
# Maintainer: Patrick Northon <northon_patrick3@yahoo.ca>
-pkgname=mingw-w64-pystring
+_pkgname=pystring
+pkgname=mingw-w64-${_pkgname}
pkgver=1.1.3
pkgrel=2
-pkgdesc="C++ functions matching the interface and behavior of python string methods with std::string (mingw-w64)"
+pkgdesc='C++ functions matching the interface and behavior of python string methods with std::string (mingw-w64)'
arch=(any)
-url="https://github.com/imageworks/pystring"
-license=("custom")
+url='https://github.com/imageworks/pystring'
+license=('custom')
makedepends=('mingw-w64-cmake')
depends=('mingw-w64-crt')
options=('!strip' '!buildflags' 'staticlibs')
source=(
- "https://github.com/imageworks/pystring/archive/v${pkgver}.tar.gz"
- "BuildPystring.cmake")
+ "$_pkgname-$pkgver.tar.gz::https://github.com/imageworks/pystring/archive/v${pkgver}.tar.gz"
+ 'BuildPystring.cmake')
sha256sums=(
- "358a56e756e701836b69a31c75d3d9d41c34d447cf7b3775bbd5620dcd3203d9"
- "1069e99aa9e546945e0f88bd4f2b06cbca8bb796843d7dc97fa428bafef60a05")
+ '358a56e756e701836b69a31c75d3d9d41c34d447cf7b3775bbd5620dcd3203d9'
+ '1069e99aa9e546945e0f88bd4f2b06cbca8bb796843d7dc97fa428bafef60a05')
-_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
+_srcdir="${_pkgname}-${pkgver}"
+_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
+_flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE='-O2 -DNDEBUG' )
prepare() {
- cp "BuildPystring.cmake" "pystring-${pkgver}/CMakeLists.txt"
+ cp 'BuildPystring.cmake' "${_srcdir}/CMakeLists.txt"
}
build() {
- _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" )
-
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "pystring-${pkgver}" -B "build-${_arch}" "${_flags[@]}"
+ ${_arch}-cmake -S "${_srcdir}" -B "build-${_arch}" "${_flags[@]}"
cmake --build "build-${_arch}"
done
}
@@ -35,6 +36,6 @@ build() {
package() {
for _arch in ${_architectures}; do
DESTDIR="${pkgdir}" cmake --install "build-${_arch}"
- install -Dm644 "pystring-${pkgver}/LICENSE" "$pkgdir/usr/${_arch}/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "${_srcdir}/LICENSE" "$pkgdir/usr/${_arch}/share/licenses/$pkgname/LICENSE"
done
}