summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPatrick Northon2020-06-12 12:05:36 -0400
committerPatrick Northon2020-06-12 12:05:36 -0400
commitf2afd3b8244100e5ce75ac2c710135f166b578e5 (patch)
tree37b40d41573334dde05fed71f4cc349894266037 /PKGBUILD
parentcdd8a109d4adb77e22f9c02617210f87643c4661 (diff)
downloadaur-f2afd3b8244100e5ce75ac2c710135f166b578e5.tar.gz
Correct compile flags.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ed15ccbe2a3e..30e082891ce9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=mingw-w64-pystring
pkgver=1.1.3
-pkgrel=1
+pkgrel=2
pkgdesc="Pystring is a collection of C++ functions which match the interface and behavior of python's string class methods using std::string."
arch=(any)
url="https://github.com/imageworks/pystring"
@@ -24,8 +24,10 @@ prepare() {
}
build() {
+ _flags=( -Wno-dev -DCMAKE_BUILD_TYPE=Release -DCMAKE_CXX_FLAGS_RELEASE="-O2 -DNDEBUG" )
+
for _arch in ${_architectures}; do
- ${_arch}-cmake -S "pystring-${pkgver}" -B "build-${_arch}" -DCMAKE_BUILD_TYPE=Release
+ ${_arch}-cmake -S "pystring-${pkgver}" -B "build-${_arch}" "${_flags[@]}"
make -C "build-${_arch}"
done
}