summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichel Zou2018-07-16 18:53:42 +0200
committerMichel Zou2018-07-16 18:53:42 +0200
commit4432c1ce44445238515afb86d7b272a3465dbcc2 (patch)
tree775e25ee905eabcafd373febf7954eb9c5225a20 /PKGBUILD
parent0fc2365b2c35a05ffeab95f4d345ee61506d8b91 (diff)
downloadaur-4432c1ce44445238515afb86d7b272a3465dbcc2.tar.gz
wine wrapper
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7bda325e9af2..d1ee52883b65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgname=mingw-w64-python2-bin
pkgver=2.7.15
_pybasever=27
-pkgrel=1
+pkgrel=2
pkgdesc="A high-level scripting language (native MSVC version) (mingw-w64)"
arch=('any')
license=('PSF')
@@ -9,12 +9,15 @@ url="http://www.python.org/"
provides=('mingw-w64-python2')
conflicts=('mingw-w64-python2')
depends=('mingw-w64-crt')
+optdepends=('mingw-w64-wine: runtime support')
makedepends=('wine' 'mingw-w64-tools' 'mingw-w64-binutils')
options=('staticlibs' '!buildflags' '!strip')
source=("http://www.python.org/ftp/python/${pkgver}/python-${pkgver}.msi"
- "http://www.python.org/ftp/python/${pkgver}/python-${pkgver}.amd64.msi")
+ "http://www.python.org/ftp/python/${pkgver}/python-${pkgver}.amd64.msi"
+ wine-python.sh)
sha256sums=('1afa1b10cf491c788baa340066a813d5ec6232561472cfc3af1664dbc6f29f77'
- '5e85f3c4c209de98480acbf2ba2e71a907fd5567a838ad4b6748c76deb286ad7')
+ '5e85f3c4c209de98480acbf2ba2e71a907fd5567a838ad4b6748c76deb286ad7'
+ SKIP)
_architectures="i686-w64-mingw32 x86_64-w64-mingw32"
@@ -30,6 +33,7 @@ build() {
msiexec /i "${srcdir}"/python-${pkgver}${target}.msi /qb TARGETDIR=$PWD
gendef python${_pybasever}.dll
${_arch}-dlltool --dllname python${_pybasever}.dll --def python${_pybasever}.def --output-lib libs/libpython${_pybasever}.dll.a
+ sed "s|@TRIPLE@|${_arch}|g;s|@PYVER@|${_pybasever}|g" "${srcdir}"/wine-python.sh > ${_arch}-python${_pybasever}-bin
popd
done
}
@@ -46,6 +50,8 @@ package() {
cp -r Lib "$pkgdir"/usr/${_arch}/lib/python${_pybasever}
install -m644 DLLs/*.pyd "$pkgdir"/usr/${_arch}/lib/python${_pybasever}
install -m755 python.exe "$pkgdir"/usr/${_arch}/bin/python${_pybasever}.exe
+ install -d "$pkgdir"/usr/bin
+ install -m755 ${_arch}-python${_pybasever}-bin "$pkgdir"/usr/bin
pushd "$pkgdir"/usr/${_arch}/bin/
ln -s python${_pybasever}.exe python2.exe
${_arch}-strip --strip-unneeded "$pkgdir"/usr/${_arch}/bin/*.dll