summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2020-09-13 13:26:47 +0200
committerMartchus2020-09-13 13:26:47 +0200
commit9280e1d248bfb72e7a48148c293136f3e0afa31b (patch)
tree1f988fe49a24c43aac535f0b1dc12c29d6d3d41b /PKGBUILD
parentf7f3ab6a6d1c54793bab2b83e1a8cbbf94182361 (diff)
downloadaur-9280e1d248bfb72e7a48148c293136f3e0afa31b.tar.gz
Update to 5.15.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 4 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 9ad53fcff98c..257db7d8fdde 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,16 +4,13 @@
# All my PKGBUILDs are managed at https://github.com/Martchus/PKGBUILDs where
# you also find the URL of a binary repository.
-# This file is created from PKGBUILD.sh.in contained by the mentioned repository.
+# This file is created from PKGBUILD.sh.ep contained by the mentioned repository.
# Do not edit it manually! See README.md in the repository's root directory
# for more information.
-# Includes dynamic and static versions; if only one version is requried, just
-# set $NO_STATIC_LIBS or $NO_SHARED_LIBS.
-
_qt_module=qt3d
pkgname=mingw-w64-qt5-3d
-pkgver=5.15.0
+pkgver=5.15.1
pkgrel=1
arch=('i686' 'x86_64')
pkgdesc="C++ and QML APIs for easy inclusion of 3D graphics (mingw-w64)"
@@ -25,16 +22,11 @@ groups=('mingw-w64-qt5')
url='https://www.qt.io/'
_pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('61856f0c453b79e98b7a1e65ea8f59976fa78230ffa8dec959b5f4b45383dffd')
+sha256sums=('29aac2c38b6b2fb1e7d54829ff8b4c9aae12a70ffab9707c7388f1e134dd9411')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
-[[ $NO_STATIC_LIBS ]] || \
- makedepends+=('mingw-w64-qt5-base-static') \
- optdepends+=('mingw-w64-qt5-base-static: use of static libraries') \
- _configurations+=('CONFIG+=no_smart_library_merge CONFIG+=static')
-[[ $NO_SHARED_LIBS ]] || \
- _configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
+_configurations+=('CONFIG+=actually_a_shared_build CONFIG+=shared')
prepare() {
cd "${srcdir}/${_pkgfqn}"