summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2018-02-19 20:15:20 +0100
committerMartchus2018-02-19 20:15:20 +0100
commit6e56ca96f388fbefc9735452c46b99ff6ca91dc9 (patch)
tree4c325cd4bebe2b27af317ee9b5d35461eae93c50 /PKGBUILD
parent4c143d65d598e69dba64195e3f46c0315e4c3dcb (diff)
downloadaur-6e56ca96f388fbefc9735452c46b99ff6ca91dc9.tar.gz
Update to 5.10.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 20 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7d31fc24f344..f8ce67e5b6ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
_qt_module=qtactiveqt
pkgname=mingw-w64-qt5-activeqt
-pkgver=5.10.0
+pkgver=5.10.1
pkgrel=1
arch=('any')
pkgdesc="ActiveX integration framework (mingw-w64)"
@@ -23,9 +23,9 @@ _pkgfqn="${_qt_module}-everywhere-src-${pkgver}"
source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${pkgver}/submodules/${_pkgfqn}.tar.xz"
'0001-Don-t-require-windows.h-when-using-native-Linux-gcc.patch'
'0002-Handle-win64-in-dumpcpp-and-MetaObjectGenerator-read.patch')
-sha256sums=('f9d74034ffe6e54278f1720d4c8c678f80882b9fffa3b698bd212f0a4b5cd674'
- '7e099a0aaa459d25eea88105179237653571ac0a2498c987ab9bdccaf118722b'
- 'e65bdeeaf11f2e905145ff3aac81a735f5d2f3c68cf5ba69f1ee36ef4b25e50f')
+sha256sums=('9021ab7e34b10b30a80d6f5e2474afa8faea10792867d459b53dd11ba23891e4'
+ 'c56ce522532663d48e88f9cc6cbcb839103a2426715dbf6b16d104e0875a30f8'
+ '17f9d460aad2f8c7143e44ef93ab145bd0d0e5b2ad0c91ff4547f11f55fb6a91')
_architectures='i686-w64-mingw32 x86_64-w64-mingw32'
[[ $NO_STATIC_LIBS ]] || \
@@ -64,6 +64,19 @@ package() {
pushd build-${_arch}-${_config##*=}
make INSTALL_ROOT="$pkgdir" install
+
+ # Use prl files from build directory since installed prl files seem to have incorrect QMAKE_PRL_LIBS_FOR_CMAKE
+ if [[ -d 'lib' ]]; then
+ pushd 'lib'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib" --parents {} +
+ popd
+ fi
+ if [[ -d 'plugins' ]]; then
+ pushd 'plugins'
+ find -iname '*.static.prl' -exec cp --target-directory "${pkgdir}/usr/${_arch}/lib/qt/plugins" --parents {} +
+ popd
+ fi
+
find "${pkgdir}/usr/${_arch}/lib" -maxdepth 1 -name "*.dll" -exec rm {} \;
[ "$NO_STATIC_EXECUTABLES" -a "${_config##*=}" = static -o "$NO_EXECUTABLES" ] && \
find "${pkgdir}/usr/${_arch}" -name "*.exe" -exec rm {} \; || \
@@ -75,6 +88,9 @@ package() {
find "${pkgdir}/usr/${_arch}/lib/" -iname "*.so.$pkgver" -exec strip --strip-unneeded {} \;
popd
done
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "${pkgdir}/usr/${_arch}/lib" -type f -name '*.prl' -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
done
# Make sure the executables don't conflict with their mingw-qt4 counterpart