aboutsummarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2016-03-09 00:26:14 +0100
committerMartchus2016-03-09 00:26:14 +0100
commit3564bd5b15c3cd1825795965e2f17a52a227d60e (patch)
tree19d1800759ad9f0152032c600e57b63f612ad86d /PKGBUILD
parentf99b20e9e886b0b7f8ebe5b939bea88364ad93d8 (diff)
downloadaur-3564bd5b15c3cd1825795965e2f17a52a227d60e.tar.gz
fixed bug caused by new ANGLE version
- enables required declarations from ANGLE headers to prevent build failure - rebuild ANGLE first since it needed a fix, too
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 219067fa243e..c8809529613a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=mingw-w64-qt5-base
pkgver=5.5.1
-pkgrel=1
+pkgrel=2
pkgdesc="A cross-platform application and UI framework (mingw-w64)"
arch=(i686 x86_64)
url="https://www.qt.io/"
@@ -252,14 +252,22 @@ build() {
# fix include directory of dbus
qt_configure_args+=" $(${_arch}-pkg-config --cflags-only-I dbus-1 --cflags)"
- isOpenGL && qt_configure_args+=' -opengl desktop'
- isStatic && qt_configure_args+=' -opengl no'
+ if isStatic; then
+ qt_configure_args+=' -opengl no'
+ elif isOpenGL; then
+ qt_configure_args+=' -opengl desktop'
+ else
+ # GL_GLEXT_PROTOTYPES must be defined to enable declarations GLES functions
+ qt_configure_args+=' -DGL_GLEXT_PROTOTYPES'
+ fi
+ # TODO: allow dynamic OpenGL configuration
unset PKG_CONFIG_PATH
if ! isStatic; then
export QT_LFLAGS_MYSQL="-L/usr/${_arch}/lib -lmysql"
fi
+
# Qt doesn't detect mysql correctly, so use this:
export QT_CFLAGS_MYSQL="-I/usr/${_arch}/include/mariadb"
#export QT_LFLAGS_MYSQL_R="-lmariadbclient -lws2_32 -lpthread -lz -lm -lssl -lcrypto"